PL 6 - Blurred image until adjustment is complete. It's normal?

My configuration is Intel Core i7-8700 - CPU 3.20 Ghz, 32 Gb RAM - Win 10 Pro x64 and GeForce GTX 1660 - 6 Gb. video card, running PL6.
I have noticed that when doing image processing, when I use the adjustments commands, the image is blurry until I finish that adjustment. Is this normal on the PL6 or do I have a sub-optimal setup?
Sorry for the sentence construction but I’m Brazilian and I’m using Google Translate to write this text.

1 Like

Hi welcome to the forum.
What you experience is normal.
Because DxO preforms each time you change a setting a new preview fresh made by demosiacing and the optical correction module activities you see some delay depending on how much recalculation must be done. I run v6 on a 2011 i7 7400 and 32 gb ram and a poor Geforce 750 ti when it is preforming an export in deepprime xd modes i have to wait until the proces is done.

In dxo preference you can see how the gpu is used by dxopl.
With ctrl alt delete you can acces the memory, cpu and gpu load grapics to see which is blocked to 100% during hard work like exporting or local adjustments with lots of masking that should be the bottleneck.


1 Like

Thank you for your reply, OxiDante. Very useful for me.

There is a check box in Preferences which prevents the movement of sliders causing images to blur while performing adjustments. It is unchecked by default. Using it may slow down older machines with slower processors. I am away from home and don’t recall what the check box is called or which tab of Preferences it is in, but I’m sure others here can assist you. Once you check it, images will not blur during slider adjustments.


this one → menu → View → …

sorry – correction !!

Live Review (Windows PC)

manual p.40

Perhaps this one?

1 Like

Unfortunately not. This option is always disabled.
I keep thinking that there is a bottleneck in my equipment and I still haven’t been able to identify where it is because my configuration is good even in relation to the video card.

Yes, that’s the one


Are you saying that you are unable to activate that checkbox? This the first time I’ve heard of that problem.


So it is. This makes me lost because I know I have a very reasonable processor as well as a very good amount of memory and a video card with good configuration. Given this, I was not supposed to have this problem that I am encountering. An interesting fact is that I don’t have this problem when I use Photoshop and Camera Raw (I don’t use Lightroom). I think it’s a memory allocation issue that Adobe programs do that DXO doesn’t and that directly affects rendering. I dare say that DXO’s memory allocation engineering is more sensitive or less performing.
If so, then the DXO people have a challenge to overcome.

If you can’t tick the box I highlighted in my screen shot then you need to report your problem to DxO here:
because you should be able to select that option.

My machine is a much lower spec than yours (Intel Core i5 3570 @ 3.40GHz, only 8 GB RAM and only a GTX 1050 Ti) and I can tick / untick as I choose. I could also do that when I didn’t have the Nvidia card fitted, i.e. when I only had the on-board Intel graphics

1 Like

see my old pc:

it’s in some parts slow on images and on other images repsonsive.
just play with the preference settings and see when it’s the fastest.

Good news
I was able to solve my blurry image problem while running some image adjustment command.
According to instructions received, it was enough to enable “Preview Quality - Always prefer quality previews”.
With the quality of my setup, the performance drop (if any) will be imperceptible.
I want to leave here my thanks to everyone who seeks to help me.
I really enjoyed entering this forum, where I will try to repay with my small contributions, whenever necessary.
Congratulations to everyone.