PL 5.1.1: Keyboard shortcut denied

I just observed an interesting new small problem: when trying to apply (copy) settings to an image with the keyboard shortcut Ctl+Shift+V, I only got an audible signal but the settings were not applied.

Using the right mouse button, I selected exactly this function and it worked correctly.

With the next image, the keyboard shortcut worked fine again.

I got this problem a few times now.
And believe me, I checked many times that I really pressed the right keys… :grinning:

no problem here – since years using a very solid Cherry keyboard

I read this quickly and thought - a keyboard made of solid Cherry wood? :rofl: :crazy_face:

This is a very helpful comment, Wolfgang…


At work we had stuff from Siemens-Nixdorf, Fujitsu …, but at home I always preferred one from
Well not quite true, over 20+ years I had two from Cherry with a PS/2 connector. Just with the last machine I had to exchange it for USB.

OK, I am also using very solid Cherry keyboards. In that case it was even one with gold cross contacts.

But, just for the record, it’s not a problem of the keyboard.

1 Like

Just a quick idea - are you certain the destination thumbnail is properly selected?

Yes, of course the right image is selected. It also shown in the big preview, and it’s possible to apply corrections. PL just didn’t accept that particular shortcut - and rejected it with a sound signal.

(After having used OP resp. PL for many years now, I think I am some kind of used to selecting images correctly… :grinning:)

I’m sorry, I was not intending to be in any way insulting. It’s just that, sometimes, when all else fails, try something stupid :sunglasses:

Equally, don’t shout at me for this but, I suggest you also try ensuring that all three keys in the chord are completely pressed each and every time? I have had times when, because of the hand shape required, one of the modifier keys doesn’t always make contact, especially on one of my older, now defunct, keyboards.

No problem, I didn’t take that as insulting.

And yes, I am absolutely sure that I correctly pressed all three keys. I even tried different orders (Ctl-Shift-V and Shift-Ctl-V) do see if that would make any difference. And I repeated the shortcut several times, slowly, precise and absolutely sure to correctly press the keys, and always got the sound instead of the intended functionality.

Eeeek! The problem we have is that it doesn’t happen to everybody and, even for you, it doesn’t happen all the time.

As a software developer and debugger, if it were my app, I would want to know exactly what you did just prior to the keepers failing. Unfortunately, that is extremely difficult if it is only intermittent and it doesn’t happen for a while, so you forget to note what exactly you did.

If it is at all possible, without sending you crazy, I guess DxO would be very grateful if you could nail down if you are doing the same thing every time it fails.

Painful but it might be the only way unless someone else finds the same problem.

1 Like

Just had a thought - do you have any other software running that uses those same shortcuts and is intercepting them before PL can get them?

Being a software developer as well, I understand that perfectly. That’s why I try to provide as much details as possible. However, in this case I can’t tell that I did anything particular. It happened just during normal work on a series of images with similar correction needs, so I was using Shift+Ctl+C on the first image and then Shift+Ctl+V on very many others. Only a few times that failed…

Of course, if that happens again, I will take care if there were any particular circumstances. (To my current knowledge, there were none.)

1 Like

Not to my knowledge.

Also note that PL was maximised/fullscreen and in the foreground, so it should have had the focus for any keyboard entries anyway. And using it with the mouse still worked fine. I even tried to use the shortcut right after having changed a correction by mouse, so it was really sure PL got the focus. However: sound, no action.

If that hadn’t been such a strange behaviour, I would not have posted here…

Ah. Then, politely put, you are stuffed :roll_eyes: :wink: :rofl:

I’m not being flippant when I say what you already must know that it must have been a month where the third Thursday began on Wednesday or some such other annoying nonsense.

I would still put money on it being a (very) intermittent modifier key on the keyboard. How about swapping keyboards to see it that makes any difference, or am I now starting to get even more silly?

That’s something I was wondering but I get the feeling Tilmann knows only too well to check for these things and is more desperately seeking reassurance that he isn’t going totally potty. But we can but hope that it is something simple that none of us have yet thought of.

I know how hard it is to find bugs that show up only rarely or at special conditions…

However, just to make sure, I can confirm that PL normally does not react with an audible signal on neither Shift-V nor Ctl-V. So it’s impossible that one of the qualifier keys did not work correctly when I got that effect. (And if the V key wouldn’t have worked, there should have been no reaction at all.)

DxO might have a closer look under which circumstances any keyboard entry could result in an audible signal. Perhaps this leads to some more information about what had happened.

One problem with debugging keystroke detection is that it is difficult to examine the point in code where the detection takes place without provoking a break in execution for every single keystroke. One technique I use is to sound a beep instead of breaking execution, something that could get just a tad confusing in this case :crazy_face: