PL 4.1.1 Rename Dialog Window Now Missing

Installed v4.1.1 about a week ago. All went well including all the new features were working in PL v4 until today. As of today, the f2 function, rename an image no longer works. I tried the rename feature both PhotoLibrary and Customize. Same result: rename function popup window missing. I can still rename a single image by right clicking on an image as we did before PL4.

That very nice dialog popup for renaming an image is missing whether I use (after clicking on an image) f2, or right clicking on an image for the context menu and selecting “rename”.

So far I uninstalled and reinstalled v4.1.1. After that I restored the latest database I have, which is today’s as I write this.

The uninstall/reinstall routine did not fix the rename issue.

Any ideas that I can try next?

Well, replying to myself, I see that batch renaming brings up the rename dialogue window as I read further down in the forum.

Issue resolved

Doesn’t work for me either
If the option is available from the context menu, or F2 or even from the Edit menu, then it ought to work

I notice that if I select an image and press F2 then the image name appears on a black background on the thumbnail but I can’t get to it to change it

Sounds like a bug that ought to be fixed.

Hello guys,

Rename dialog appears if you select more than one image (because the feature is a batch renaming), if you try to rename just one image -> it’s still the same procedure - the name of the image gets the edit state.

Svetlana G.

I appreciate that but when I select ONE image and press F2, the image name appears on the thumb name on a black background, when I move the mouse to this entry field, the field disappears and hence I can edit it