PL 1.2: A lot of crashes since the new version

Wow. After upgrading to 1.2 PL sure crashes a lot. Especially when using “local adjustments” (like depth, mid-tone adjustments and such). I already tried sending crash reports to you, but before the step was done, the whole program stopped working - including the debug system.

Is this a known issue right now? What can I do to help?

Windows 10, 64-bit, no Antivirus except default Windows Defender
Ryzen CPU, 8x 3,6 GHz, 16 GB RAM, nvidia 1080ti, latest drivers

Just another user here, but I would try disabling the use of OpenCL, if you have it enabled, and then try to make it crash again.

Just so you know, I am running Win 10, 64bit, WD AV, 4 core Haswell CPU 3.8GHz (i7 4770K), 24GB RAM, using default Intel graphics on MB (Asus Z87-WS), OpenCL disabled, and no problems with crashing.

I’m running on the latest version of Windows 10 64 bit with no issues. and have Open CL selected. Try unselecting it, but I suspect the problem lies elsewhere and its unlikely an issue with PL. Did you try uninstalling and reinstalling it?


Yes, I already uninstalled PL - re-installed it. The crashes seem to be random in nature. Sometimes the procedure (local adjustments) work on some images, sometimes they don’t - and everything just breaks. PL seems to have issues while switching back & forth from one image to another, while PL is still working on “adjusting” the last one. This also led to a few crashes just now.

OpenCL is grayed out in my settings. I am not able to select it. Maybe nvidia cards are not supported?

I have a GTX 1070, not a single crash so far. What is ‘special’ about your system is your ryzen. Hope this has nothing to do with it, because multi core problems and race conditions occure more often, if the number of physical cores increases.

970 FTW here. Intel Z97, Devil’s Canyon 4790K CPU, 16GB RAM. W10_1803, PL Elite v1.2. No crashes for me.

If you are overclocking CPU or memory, revert to stock settings and re-enable Open CL. Like Mark, I think the issue is probably elsewhere.

Thanks for your input. I actually didn’t overclock CPU / RAM. It’s basically “default” for my system. Plus enabling OpenCL is not possible in my settings. Don’t know how you managed to do it. :wink:

If you’re all fine, it could be an issue with my system configuration, but experience tells me, it mostly has to do with programming (being a C++ dev myself). Anyway. Thanks again!

EDIT: Too many cores could be indeed an issue, as Asser already mentioned.

You can try to limit the Photolab process to use only 4 physical cores through the windows task manager, just to see, if it changes something.

I am also a developer and we had a MSBuild setup which ran for years without issues. This changed after I got a Ryzen 1700 CPU for my new developer PC. This caused immediate problems with race conditions during the build, because multiple processes tried to access the same files at the same time.

Which nVidia card do you have? I have a nVidia GeForce GTX 745 card, which is far from high end, and it work just fine.


Thanks, Mark!

This is actually a good idea. Will try that - although I am away for a few days. I hope to get back to you guys at the end of the coming week.

Hello @moonwhaler,

Could you, please, attach any of your crash log here (you can find them under “c:\Users%user_name%\Documents\DxO PhotoLab crashes”) if you select “Do not send” on a crash log screen?

  • It often happens if the drivers to you graphic card are not updated. Please, update the drivers manually and check again.

Thank you
Svetlana G.

Hi @sgospodarenko!

I was not able to obtain the crash logs (yet), but I just re-installed my nvidia graphics card drivers to the latest version (398.36), did a restart of the whole system afterwards and re-installed PL again. Still, I am unable to select OpenCL. (“restart required” - even, if I did that already.)

@moonwhaler (Chris)

Open CL is definitely supported in 398.36, 1080Ti, W10 x64, builds 1709 or 1803.

What motherboard do you have? Are you using MSI afterburner or other acceleration app?

Did Open CL ever work in your environment?

Hello @moonwhaler,

“Requires restart” is a permanent hint, just to remind you that you need to restart your machine just after the enabling of this option.

Could you, please, provide us with the logs here or create a support ticket - and attach your logs there.

P.S. You can find your logs here - c:\Users%user_name%\Documents\DxO PhotoLab logs\

Thank you
Svetlana G.

Thanks for your input. I already created a ticket @dxo.
I am using MSI Afterburner - and already deactivated that + restarted my pc & PL. Same result.

My motherboard is a ASUS PRIME X370-PRO.

OpenCL was never selectable in my PL environment. Other software works fine, although that might use CUDA. Like Blackmagic Davinci Resolve Studio (14 + 15b).

If you have afterburner installed, make sure that rivatuner statistics server is not running. This tool hacks itself into processes and caused Affinity Photo to crash on my system all the time until I uninstalled it.

Have you installed chipset drivers?

AMD Chipset driver
AMD AM4 Chipset Driver V5.12.0.38 for Windows Win10 64bit. (AMD package version is V17.40.3765, VGA driver version is V23.20.840.0)

Asus Downloads

You should also capture the logs Svetlana is asking for… her devs might key in on something.

@Asser: Riva Server was never running. I switched it off entirely - MSI Afterburner works without it, but thanks for your help!

@shadowsports: I recently installed 18.10 of the AMD chipset drivers, but I will try the ASUS supplied drivers, too. Thanks! Plus I send the logs to the support staff a few days back. :wink:

Edit: I won’t try the ASUS ones, as they’re not up2date. The official AMD ones are @18.10 whereas the others are 17.7.

That’s fine. Latest isn’t always best, but wise to hold off until you hear back from Svetlana and her group. Hopefully they come back with something.