Photos disappearing PhotoLab 7.6 build 53

Photos keep disappearing when trying to apply local adjustments. Fix it, please!
Yes, and constantly crashing.
Photolab 7.6 build 53
MacOS 13.6.6

Same problem here, after or while using the local adjustment the pictures disappeared and PL must be restarted. very bad :frowning:

I must switch to the previous version, again …

Hi Wolf,
I will try to downgrade to 7.5 too. Do you know how to do that?

I have a Timemachine backup with V7.5.1.

Yes, I did not remember it. I still have it on TM. Thanks!

Mine too - if I edit a second image and try and apply an Auto Mask the image immediately disappears and I have to restart the application.

Phew some testing process they must have - just sign a few of us up as Beta testers to avoid this DxO !!

Be sure to submit a bug request to DxO.

I finally installed 7.5 which fixed an earlier problem I had with the previous versions after 7.02 concerning the synchronisation of metadata between PhotoMechanic and Photolab. Glad for that.

I will not install 7.6 after these reports I have read the last day about missing pictures e.t.c.
Sad to see DXO continuing deliverance of new versions without testing them.

… and how many new updates have we got now since version 7 was released last year without the slightest indication that DXO will fix all the well-known problems we have reported since then?? … and why no upgrade to the latest version of Deep Prime XD (XD2 that currently seems to be shipping with PureRaw?

Beta testers did not miss this problem. According to the posts above, the problem developed in PL 7.6 build 53, and it did not exist in PL 7.5. Perhaps the Beta testing procedure is flawed and that is why DX0 have changed it, but it is possible that in fixing something programmers introduced a different bug.

This apparently is in the Mac version and not the Windows version.

So what NO Beta Testers at all for v7.6 ???

I have the same problem here and have submitted a support request. DxO needs to pull this download for Mac users ASAP and provide a link to the 7.5 download for those affected.

The error seems to be recorded System Log, and looks to probably be macOS specific. It would be trivial to debug - just running PL7 in a mac debugger should catch the error.

What is beyond astonishing is that the software was released in this state. The most cursory developer testing should have caught the issue with ease, let alone any formal release/test procedure. Words fail me.

There’s an update for PhotoLab 6 too. I have not yet installed it for obvious reasons.

When a current version of DPL is updated, there often are updates for all other products plus the previous major versions of DFP, DPL and DPR too.

I did not talk about 7.5 which is fine in this respect.

FWIW, the problem is in the LocalCorrections palette and is caused by removing a non-existent NSObject key-value-observer, triggering an unhandled exception. Disabling the offending exceptions allows 7.6 to run normally with local edits. Unfortunately, this is not a practical workaround as it needs a patched executable which is only possible with a developer system and a lot of risk.

Hopefully DxO will release a fix promptly, as it does not look difficult.

This is very macOS specific, so I doubt that Windows builds are affected.

On Windows ( on my system) , this problem is not present.

Testing with DPL (updated copy of 7.5.1) on macOS 14.4.1 on 2019 5K iMac (Radeon Pro 580X 8 GB)

  1. Activate the LA tool panel
  2. Expand the LA tool panel
  3. Click to add a control point
  4. Add the control point
  5. Change HSL
  6. Increase sharpness
  7. Duplicate mask
  8. Invert mask
  9. Resize control point
  10. Apply Bokeh
  11. Resize control point, change chroma/luma selection sliders
  12. Close LA

Everything worked as expected. Note that I had resized DPL’s window and worked with the “Advanced Workspace”.

I then selected the next image and as soon as I clicked on a LA option (e.g.control line), the preview was gone with zoom level displaying 0% and preview not reacting to any input, be it by buttons or numerical entry…but let’s be more specific:

  • buttons “fit” and “1:1” did nothing, the zoom level still displayed 0%
  • entering “100” in the zoom level numerical field set the level to “100%”, still the previews are gone.

I remember having seen an issue with zoom levels in earlier versions of DPL, but cannot say, which version it was.


  • Restarting DPL 7.6 brings back the preview and ability to LA ONE image.
  • Switching to Photo Library view was inhibited too.

All things considered, I propose that DxO pull the update to 7.6 and set up an “update” to 7.5 instead - if that is possible at all.

Falling back to DPL 7.5.1 brought up another issue:: Closing LA and everything else was inhibited, complete freeze of the app! I was able to reproduce the issue! After deleting the database and cache files, DPL seems “back to normal”.
@Cecile-C I’ll PM the diagnostics or would you prefer to have them on the too?

I had the same problem with 7.5.1, photos disappearing too. Strange, very strange.
Come on DXO, I need to work! Fix it again Tom.

Are you referring to this cache here ~Library/Caches/com.dxo.PhotoLab7 ?

@platypus Thanks for bringing your issues to our attention. We are aware of a bug with local tools on Mac. An update to fix it will be release ASAP. Can you please wait for it before contacting the support?

1 Like

But they still did not, now 17h later. I’ve just fallen into the same trap. Not funny.