Photoloab 2 PhotoLibrary no longer recognising photos

Since upgrading my MacBook Pro to OS Catalina (beta), the PhotoLibrary tab is no longer finding any images.

The filters are all selected (show everything), so I don’t think that is the problem.
Surprisingly, anything in a project still shows up ???

I know I am using a pre-release version of Apples new operating system, but its close to being released and i wonder if this is something DxO needs to fix.
OR, am I doing something stupid in PhotoLab (more than possible)

Thanks for any help


Check here for more on Catalina experiences and a statement by DxO…

Early betas of macOS usually do strange things at times and I just recently installed it several times and got varying results. It can be fun to play around with these betas but I‘d rather not waste too much time with them.

it says ‘sorry you don’t have access to that topic’

Here’s one of the comments by DxO staff:“…We’ll be installing the Beta in the coming weeks to start proofing … against it. We’ll take a look at this issue, as it can be quite blocking. But then, remember that Apple Betas can be quite jumpy :wink:

If you look at your beta install, you‘ll find two volumes. This is new and used to separate system and user resources. So far, I‘ve not tried too hard to understand it and I don‘t want to spend a lot of time to figure it out (I do not have a developer documentation)

Indeed, as I stated in the other topic to our beta testers, the Apple betas are usually quite a ride, with some issues appearing out of nowhere, only to be fixed by Apple a release or two later. We’re only at the 2nd developer beta, and the 1st public one, so there’s still quite some time before it’s released (probably around 3 months).
Even if those betas are public, it is always recommended that you not install this over your main OS. You should make a partition to install it separately (which is made even easier now with APFS), and just install those for curiosity’s sake and not actual work, otherwise you’ll probably lose quite some time with such issues.

That being said, this issue has been reported and we’re in the process of fixing it, but please understand that while that fix may be released soon on the beta versions of PhotoLab, it may be some time before we release an update to PhotoLab 2 to fix this issue, as Catalina is still quite far from being released, and it wouldn’t be reasonable for us to focus on this instead of working on new features for you guys.


This is exactly my experience, specially with early betas.

Meanwhile, I have installed the public beta a few times in different manners and got very different results. I used to see the Catalina root AND data volumes, with the newest installation, I can only see one volume. Just to illustrate what a ride it can be.

Better go out and take a few photos - unless your weather is as hot as it is here…

That totally make sense, Catalina should not be the priority today but it is nice to see you already have an eye on it :slight_smile:

Well, Mac Catalina is due to be released in less than three months, and no other app that I have suffers from any of these problems, and there is no sign of anyone reporting about this type of problem in the Mac developer communities (I am a Mac/ios developer myself).
Of course it is up to you when you decide to look at this problem, but I’'ll have to switch back to Photoshop until this is sorted - which is a shame as Ive just spent a small fortune on all of your software products and upgrades, as well as buying a DxO One camera - all within the last few weeks.

Hi Dean,
As mentioned above, a fix is already being prepared.
You will agree, since you are also a developer, that it is a bit early for Catalina and saying « it is a shame » don’t you ?
I am also a user and I expect to use Catalina this autumn with DxO products too.


I appreciate that DXO does not spend too many time in trial&error stuff for making this work but is prepared and before releasing waiting for the official technical specifications. This is just too time consuming.

And please be aware that relying on an operating systems which is not even released officially with no support is not professionell. Please do not blame DXO for this. Thank you.


Hi All

I have just upgraded to the latest beta of Mac Catalina (10.15 build 19A512f), and this problem no longer exists, so now I can use Photolab again on my Mac

Stange, I have always had that issue. I thought it was logic, Click on a folder with a folder in it, then it won’t see any images, just the folder.

OP as a matter of interest if you click on the HR Res folder, did that show any images?


I recently installed Catalina. DXO 2 and now tried DXO3 can’t find photos. The Photos Library shows, but there’s nothing in it. Depressing.