PhotoLab Won't Open

PhotoLab 1 installed on Win 7 computer. It doesn’t want to fully open and function. That is, the PhotoLab opening screen appears. It indicates that progress is being made opening the app as the blue bar progresses across the PhotoLab opening screen. Then PhotoLab opens to the last picture folder that was used showing the first photo in the folder. Everything freezes and the screen and photo lose contrast. Contacted DXO which indicated that service is no longer available for this version. In any event, is there a repair feature that can be employed to correct the problem? I do have a backup disc but it doesn’t have latest updates that were offered after burning the backup disc. Thanks for any help.

I assume you have already tried rebooting your computer, but if you haven’t go ahead and do that.

Were any changes made to your computer? Have you installed any new software, or upgraded your antivirus software? Which antivirus program are you using?

Since PhotoLab 1 and Windows 7 are both old and no longer supported, resolving this could be difficult. Even reinstalling the software using your backup disk probably won’t work since to reinstall PhotoLab the software must communicate with DxO which probably will no longer recognize it.


Well using the backup disc worked like a charm. PhotoLab is up and running. Had to reinstall all the camera lens profiles. All worked except for one. The Sony DT 2.8/16-50 won’t install even though the download is offered. Here’s the error message received; The remote server returned an error: (404) not found. Odd that the lens is offered. As to using the backup disc to reinstall PhotoLab, I don’t know if it includes any updates that may have been offered after the backup disc was created. One other curious event also occurred. Tried to initially utilize the repair feature offered when downloading from the backup disc. It didn’t solve the problem. Had to completely remove PhotoLab from the computer before it was possible to install it.

1 Like

@outerbank10 any advice you get from any of us is clutching at straws many are on Win 11 (I am not, yet) and much later releases on DxPL, although I did install PL2 recently (on Win 10) to investigate something which changed on that or the next release! So on one of more of my machines I have all releases from DxO 11 to PL7EA installed except PL1, but that doesn’t help you!

So I would try this to see if PL1 will “settle down”

  1. But first is this a re-install or just a re-use of an existing PL1 release? When was the last time it was used?

  2. Temporarily change the name of the directory that it is trying to (re-)open to see if it can be coaxed into just waiting for a directory to be selected, i.e. not freezing in some other way.

  3. Consider temporarily removing the database (e.g. change .db to .db.sav) so that it makes a new one in it default location just in case there is something there that is causing an issue.

  4. I presume that you have not got any data (database or DOP) from a later version of DxPL(Win) anywhere for PL1 to “trip” over.



PS:- Ignore the above since you have solved the problem for yourself, have fun. I have only one version of PhotoLab 1 in my “collection”

1 Like

Thanks for the response, Bryan. After reinstalling from the backup disc PhotoLab is correctly functioning. For some reason it’s still not possible to download the lens profile Sony 2.8/16-50 SSM for the Sony A77ii camera. It is offered for download but instead the following message occurs: The remote server returned an error: (404) Not found.
I wonder if the error is the result of the version of PhotoLab being no longer supported by DXO, or another reason. Interestingly, it was possible to download the same lens profile for a Sony A100 and A57 camera. Again, PhotoLab offered the Sony 2.8/16-50 SSM for download to the A77ii, but the download didn’t work.

1 Like

I just made another attempt installing the Sony 2.8/16-50 SSM lens on PhotoLab 1. It worked this time by selecting Sony A77 not the A77ii. I don’t know if this will make much difference in whatever lens correction is applied, but the download was successful.

1 Like

Unfortunately, the download for the Sony A77 and the 2.8/16-50 SSM lens doesn’t work on the photos. It doesn’t make any changes to the photos taken with the Sony A77ii camera. Oh well, it was worth a try.

Glad to hear it.


That’s unfortunate. But given the situation, you’re currently in better shape than I thought you’d be. Did you try removing and re-downloading that optical module?