PhotoLab does not show Geodata/GPS data of the RAW file anymore

I usually record geodata/GPS data directly in the RAW file while taking photos using my camera and smartphone. These are then displayed correctly in PhotoLab. Occasionally, however, it happens that the Bluetooth connection between the smartphone and the camera does not work or does not work quickly enough and the corresponding fields then remain empty. In these cases I enter the data with the small program GeoSetter (uses ExifTool), as well as my IPTC data.

All of this is usually displayed correctly in PhotoLab and later exported to other formats. Sometimes I even had GeoSetter and PhotoLab open at the same time and was able to add missing geodata to the RAW file while editing with GeoSetter. These were then immediately displayed in PhotoLab.

Today all of a sudden it doesn’t work anymore. Even if I open and close both programs individually, the newly entered GPS data are not accepted in PhotoLab, although other programs, such as IrfanView’s Exif display, display them. So they are there. I have no idea why. Does anyone have an idea what I can do?

Windows 10x64 Pro
DxO PhotoLab 5.3.1 (4762) with ViewPoint and Filmpack
GeoSetter 3.5.3 with ExifTool 12.43

GPS coordinates don’t show on Mac either…
…unless they come along in XMP sidecars.

GPS data added by a Canon camera-add-on at shoot time.

When I try to see the coordinates with exiftool, I cannot see them in clear text, they must be present though. Maybe I haven’t got the right parameters to see coordinates?

Last week I had another photo session and the camera recorded all GPS data during the shooting. When I opened the RAW files in PhotoLab all GPS data were shown and later (after editing the images) exported to my JPG files.
At that time I used Exiftool 12.42 together with GeoSetter. But I don’t see any difference to 12.43.
What do you mean with “show the coordinates in clear text”?

Oh, I forgot, this is an example where it worked properly:

Mummm… on my MacBook Pro Monterey with DPL 5.3.1 I can see raw embedded GPS data correctly:
Capture d’écran 2022-07-10 à 16.33.58

And in the exported jpeg as well.

Seems to depend on how coordinates are saved in the file.

I just used Nikon’s SnapBridge app on my iPhone, connected via Bluetooth to my Nikon D850.

The camera writes the following (degrees obfuscated)…

[EXIF]          GPS Version ID                  :
[EXIF]          GPS Latitude Ref                : North
[EXIF]          GPS Latitude                    : NN deg 38' 50.03"
[EXIF]          GPS Longitude Ref               : West
[EXIF]          GPS Longitude                   : N deg 35' 0.65"
[EXIF]          GPS Altitude Ref                : Above Sea Level
[EXIF]          GPS Altitude                    : 96 m
[EXIF]          GPS Time Stamp                  : 13:30:25.61
[EXIF]          GPS Satellites                  : 00
[EXIF]          GPS Map Datum                   : WGS-84
[EXIF]          GPS Date Stamp                  : 2022:07:10
[Composite]     GPS Altitude                    : 96 m Above Sea Level
[Composite]     GPS Date/Time                   : 2022:07:10 13:30:25.61Z
[Composite]     GPS Latitude                    : NN deg 38' 50.03" N
[Composite]     GPS Longitude                   : N deg 35' 0.65" W
[Composite]     GPS Position                    : NN deg 38' 50.03" N, N deg 35' 0.65" W

… which PL5 reads fine…

Capture d’écran 2022-07-10 à 19.35.54

You might like to check which tags are being written by GeoSetter.

This is, what GeoSetter shows in the input fields when you edit the file:

And this is the result that I can see with IrfanView in the exif data of the RAW file:

It’s the same what I did all the months and years before, I did not change anything.

Can you use ExifTool directly from the command line and copy the output here?

@Joanna, if you tell me what you mean exactely what I should do. I have never used ExifTool from the command line.

In that case, it might be safest if you could post the RAW file here if it is not too big. Then I can read it here.

Hi Ralf

I received the file you sent me and can find nothing missing in it. PL5 reads it fine.

The only thing different to my example file was the yours had XMP tags as well as EXIF and Composite, but that shouldn’t (didn’t) make any difference.

Opening the file in Preview on a Mac also shows the correct coordinates and clicking on the link takes me to Google Maps or Apple Maps at the correct place.

Is there any chance you had opened the image in PL before setting the GPS?

I took your file, copied it, and manually stripped all the GPS metadata from the original.

I made sure that PL5 was closed and deleted the database.

Then I opened the original file in PL5 and it showed nothing in the GPS panel - as expected.

Next, I closed PL5 and renamed the copy (which still had the GPS in it) to its original name and, upon opening PL5, there was nothing in the GPS panel, even though what I had effectively done is added the GPS metadata back in…

Capture d’écran 2022-07-10 à 22.12.23

But, on the thumbnail, the “metadata out of sync” icon was showing…

Capture d’écran 2022-07-10 à 22.12.34

Upon clicking on this icon and selecting to read from the image, the GPS metadata once again became visible…

Capture d’écran 2022-07-10 à 22.20.14

Does this explain what might be the problem?

Thank you, @Joanna, for testing.
Indeed I had opened all files in PL before adding the GPS data and had changed two settings to all files (DeepPrime and the lens sharpness), so that *.dop files for all files where created. I chose this order because I thought it would be less work if I only entered the GPS data manually into files that I want to keep, not all of them.

As I wrote above, I have often done this in the past by editing and renaming images at the same time and entering GPS data afterwards or during the process. I just had to refresh the screen view sometimes. It was never a problem.

I can no longer say whether the last time was with this version of PL or with a slightly older one.

Do you think I should delete the entire database and then import the images again? I’d hate to reset all the photos to zero because I’ve edited quite a few.

This little thumbnail, the “metadata out of sync”, is visible but greyed out. Nothing happens when I try to click on it.

If you have set PL5 to auto-sync DOP files, don’t use history or projects, deleting the database will simply cause PL5 to rebuild the database from your DOP files.

If you are not comfortable with that, copy the three database files elsewhere before deleting them.

If you have set PL5 to auto-sync metadata as well as DOP sidecars, this could be why the “resync” icon is greyed.

I don’t use projects.

That should be fine. But still copy the three database files, just for peace of mind.

OK. Do that tomorrow. After a hopefully good night’s sleep. :slight_smile: Thank you for your patience.

By the way: I set ExifTool back to the last version. No difference.

And if nothing helps I think I also set PL back to an older version and test it.

Good morning everybody!

I have now renamed the database folder and created a new one, so that PL could read all the data from the *.dop files and create a new database file.

Nothing changed. The GPS data are still not imported and visible in PL. And they are not written to an exported file.

Could you post the DOP file? I’m wondering if the “empty” GPS is written in there.

Joanna, I’ll send it to you because it contains personal data. I think the GPS can not be in it because PL did not recognize or import it. Otherwise it would show the data in the appropriate fields.

Received. You are right - there is no GPS in it.

This is odd that your version of PL5 can’t read because it is definitely in the image file.

Has PL5 created an XMP file as well? If so, could you send me that?