PhotoLab 6 won't start

Tried to update to latest version 6.3 but after installing & program is started it just gets stuck on loading splash screen… program itself won’t start/load. Tried to rollback to versions 6.2 & 6.1 (which I still had copies of) but same issue. I don’t use this software that much but v6 certainly worked okay when I bought it but since then I’ve just updated new versions over the old without checking so cant be certain when this ‘broke’. Tried uninstall / clean reinstall but same issue… can’t get past the splash screen.

Any advice on what could be the issue would be appreciated!

@JasonUK this issue has been fixed in the new update 6.3.1 released today, please download it from your customer account

v6.3.1 didn’t fix issue for me… I see that others are reporting issues with Avast AV which I also use and that only a full uninstall of the AV cleared the problem. I’m reluctant to do that as AV is more important to me. The app is taking up c25-50% CPU though when ‘stuck’ on splash screen.

@JasonUK I’m sorry to hear that you still having this issue. Indeed, it seems the problem is related to Avast. Could you, please, create a ticket via
You’ll be personally assisted there.