PhotoLab 6 stuck on Splash Screen when opened

Not sure when this started happening as I haven’t used v6 Elite that often since purchasing and have just been updating new versions including latest v6.3 over existing installation but have since uninstalled and tried reinstalling v6.1, 6.2 & 6.3 all with the same result… on opening the splash screen is displayed but no progress is shown on what I presume is a progress bar on the splash screen. I know v6 originally worked as I tried that when it was first installed so something has changed since :frowning:

I’m using WIndows 10 22H2 on a relatively old PC (i5 4460S @ 2.90Ghz) but never had a problem previously with PhotoLab 2-5.

Not sure where to start in trying to pinpoint why PL6 doesn’t open. I’ve tried disabling AV but that didn’t solve anything. Any assistance/suggestions welcome!

Avast deactivation doesn’t work, it must be uninstalling it completely.

Problem fixed with release of PLv63.1 … See here.

I know it was a typo but it made me giggle to think that it took 57 full versions to fix it :stuck_out_tongue_winking_eye: