PhotoLab 6 crashing

I’ve been experiencing problems and crashes with PhotoLab 6. These aren’t at launch, it’s when I have sets of conversions queued up. There are two main behaviours:

  1. A couple of the images in a set are left out of the processing queue, which simply stops and sits there counting up the time but going nowhere. I can cancel that set of outputs and PL will move on to the next, but I always find that two out of the (typically) 12 shots in the set aren’t processed.

  2. Straight-up crash, triggering the macOS crash reporter window.

This is processing Nikon D850 RAW files, and I’m using macOS Monterey (12.5) on the last-gen Intel MacBook Pro, with 64GB of RAM. I have various things also running, but there’s more memory free than there is used. When I go back to PhotoLab 5 I don’t experience any crashes.

Hi Keith. Are you using DeepPRIME or DeepPRIME XD on your photos? If so, what video card are you using? Have you enabled your specific card in Preferences>DeepPRIME Acceleration?

Nope, neither – I’m just using High Quality in the DxO Denoising Technologies panel. It just crashed on me again, and the Crash Reporter details said “VM - Fault hit memory shortage” despite there being more than 50% of physical RAM unused AND over 400GB of space free on the system volume. (In case it’s relevant, this MBP has an 8GB AMD Radeon Pro 5500M graphics card as well as the standard Intel UHD Graphics 630. DeepPRIME acceleration is set to Auto, with the AMD hardware chosen for me by default. But I haven’t been using DeepPRIME at all.)

For clarity, I’m reporting that DxO PhotoLab 6.4.0 build 47, for all its superb features, has a memory leak that eventually leads it to crash. As soon as I’ve struggled through the set of images that I’ve prepped for export (PL v5 doesn’t read the PL v6 .dop files) I’m dropping back to version 5 until I see that DxO have fixed the problem. I’m losing hours here – as I have a choice I’d MUCH rather lose the new features. :exploding_head:

One more thing that you can try: Check your VM settings and make sure that Paging and Swap are set to auto for all discs in your system. Also check the the PL6 memory cache in preferences and make sure it is at least 2GB. I had the same problem on an earlier version with crashes on my 32GB machine where only 50% of the 32GB was being used and the combination of these two fixes solved the problem. You never know which disc that some primary or secondary process might use when it needs VM, nor do you know when this might happen.

macOS do not offer such adjustments of VM etc.
Adjusting maximum cache size in PL6 is available though.

Good point, as I have no knowledge of MACOS. I simply included that suggestion “just in case”.

Have you tried clearing the cache in the advanced settings?

Also I have had my whole M2 Max MBP crash to black screen while batch processing photos on export. I have had to resort to just using the Nueral Engine Only setting since my whole MBP crashes with the CPU and GPU only settings. This has all occured after the latest update of DxO Photolabs6

PL6’s cache size may be the ticket. It’s at its default: 1000MB, and it’s currently at 675MB full. I’ll set it to 4096MB and try queueing up sets of conversions.

1 Like