Photolab 5 does not read metadata reliably.

Metadata contained in XMP Sidecar (e.g. in DNG or ORF files) are sometimes read in, sometimes they are not read in. This applies to keywords as well as GPS data or location information. This effect also occurs with JPG files. It doesn’t matter if the metadata is embedded in the files or written in the XMP files. All other programs (Lighroom, GraphiConverter, CaptureOne, ON1-PhotoRaw) always read the metadata reliably.

In PL5, the metadata is sometimes read in and sometimes not read in for one and the same file.

I have cleared the cache, but this had no effect.

Thanks for suggestions
Greetings Ralf

Good morning @RB-DxO and welcome to the forum,

Could you, please provide us with some samples (image+xmp+ .dop if any) for the analysis?

Please, upload them via with your forum name and let us know when ready.

Thank you
Svetlana G.

Hi Ralf and welcome to the forum!

Have you tried the menu option to re-read the metadata? What happens if you do?

Judging from your using GraphicConverter, I assume you work on a Mac.

XMP-data in general will get updated with File - Metadata - Read (as platypus already has written) but the keywords are a diffrent thing as I have experienced. The refresh/rebuild of the keyword list will just occur when you “reindex” the topfolder of your image folder hierarchy or reindex your ative image folder.

I also have seen that I have to “refresh” when using the “search function” in the PrictureLibrary and to do that I had to right click the top folder and select “refresh” in the menu.

DXO should really look into this “update problem” I think you have to automate these processes and always update even the metadata when opening av folder in Photolab 5 for editing. I think even Lightroom is manual when it comes to read metadata from external XMP-editors. Leaving these things to the users is bound to lead to confusion and unsync between integrating systems.

1 Like

…is what I expect, together with an option to update (blindly)…


thank you for your suggestion. I tried to read again the metadata and it works with the JPG and the ORF files, but not with the DNGs (Ricoh GR3). I tried a lot of things and will report:

I have narrowed the problem down to only having problems with the DNG files.

In PL4 everything works as it should. I see all the metadata in PL4, but in PL5 the metadata is not visible (even after a reload).

Interestingly, if I re-export a DNG file in PL4 that has metadata but I can’t see it, the metadata of the new file is visible in PL5 (but the GPS data is missing). However, this approach is not practical because the newly exported files become much too large.

I have opened a support ticket and hope for help from there, it seems to be a bug in PL5.

Best regards and thank you all

Could you post one of your ORF files and its XMP?

Please post one of these DNG files here, if you would like us to have a look.

I have the same problem with some folders.

Star rating set in LR Classic (2022). PL 4 reads it, PL5 does not.

“Read” metadata means I have to set PL 5 to show all files, select all, read, then reset the filter to 3 stars to show the images I want.

This just wastes users time and is an obvious bug to be fixed.


On my Mac, star ratings are shown as expected.

A few things must be set or done to show the stars:

Yes, for Auto Sync there is a warning about “loss of data” that refers to the user guide… which says Nothing about it.

Which data, DXO’s or Lightrooms that it is supposed to be able to read?

Can anyone confirm that it is NOT Lightroom data that will be lost?

Anyway, the problem is erratic here. Some folders are read, others not. No obvious reason (same drive, same camera, same LR setting (Star rating) etc.). [Win 10 not Mac]

IMO overwriting LR data is not acceptable.