Photolab 5.6: Only JPEGs displayed after update

Hi there!

Just updated to PL 5.6 just to figure out: PL can’t handle RAW files any more on my machine!

Although the photo library displays thumbnails of the RAW files, whenever I try to edit them, only the embedded JPEGs are displayed. This happens with NEF, CR2 and DNG files of all kinds.

Till yesterday PL 5.5 worked flawlessly. Is there a new switch I missed? One that says “Always edit the 8-bit small size JPEG instead of the propper RAW file”…?

I’m grateful for any hints…


No such thing with DPL 5.6 on macOS.

There is for Windows.

I’m using PL 5.6 and have not had this problem. I can still process my .CR3 RAW files as I always have. As in I can apply whatever edits I choose and then export and the exported file includes my edits. So when you say:

what do you actually mean? Can you give more details on what is / is not happening?

I have the same problem with Pl 6.1 vs 6.0.1

I’m glad I didn’t update my 5.5 on my secondary computer :-/

For stuck, I think he have somethink like that (960x720 is the embeded jpg into the .dng) :

What setting in the Windows version of PhotoLab do you believe lets you see only the embedded jpeg in a raw image while editing? I am not aware of a setting to do that and I am pretty confident that one does not exist in both the Windows and Mac versions.


I am not seeing this problem in my Window’s version of PhotoLab 5.6 and there is no setting which only displays the embedded jpeg in a raw file.


I don’t, I misread what @platypus had written - sorry for the confusion.

1 Like

No problem. While I am very familiar with PhotoLab’s features, options and settings, I don’t necessarily have all of them memorized. Even with five years of almost daily use there is always the likelihood of new things for me to learn.


It’s don’t happen with all raws. I don’t have this problem with raw from my D500, only with the .dng from my mavic 3 (and only with 5.6 and 6.1 version of photolab, 5.5 and 6.0.1 work just fine)

Does anyone know a download link to the previous version (5.5)?

And same question for 6.0.1 ^^;

@VMB, @MathieuB

just tried – no problem here
(with supported camera / lens)

the handling with DNG involved is something else, which I did NOT try

Lucky you! On my machine PL 5.6 can’t display files of my D60, D7000 and D7500 (all Nikon) any more as well as all RAWs of my Canon 5D…

Perhaps someone is willing to share the download file/installer of PL 5.5 here…?

Yet in your original post you say it does display the files. I can’t visualise what is happening. Can you post some screen shots to illustrate your problem?

You have checked that it’s not that you’ve somehow set a filter in the photo library that is hiding your files?

@VMB and @MathieuB Why do you believe you are looking at the embedded JPG rather than the converted RAW? Without any snapshots we are …thank you @stuck

Here is a RAW on PL5.6.0

Please note the RAW white Balance is showing detail only shown when working on a RAW

Here is a JPG with the different RAW White Balance layout giving the much reduced facilities available to a JPG image

There is no switch that I know of and I because the new versions are now available the update wants to download those for my old PL5.1.4 so I cannot help there and with an upload speed of 0.5Mb I cannot upload the code files that I have secured for all PL5 and PL6 releases!

I am currently running PL5.6 and PL6.1 on one machine and PL5.5 and PL6.0.1 on another so if you have the bandwidth to upload an image or two then I can try on both releases etc…

Sorry, if my post were not clear enough… This is what happens after I have upgraded to PL 5.6 (on Windows 10 / 22H2):

  1. In the photo library every RAW file is displayed as a thumbnail under it’s correct name. All metadata (keywords, EXIF, IPTC) are displayed correctly as well.
  2. In customise mode the metdata panel shows the correct data, too. One example: “NIKON D7500, 5568x3712, ISO 100, f/5.6, 1/250s, 85mm”.
  3. BUT: The image displayed (in customise mode) is just the embeded JPEG of 960x720 pixels! At 100% it just fills half of my screen and shows strong compression artifacts (see attached screenshot taken at 1920 x 1080).

Good Lord! Managed to find an installer of PL 5.5 on a backup HDD. So, I am back in the game. RAW files are displayed in their full glory again!

Just to compare: Attached is a screenshot (at 1920 x 1080) displaying the same image in PL 5.5 at 100% (no embedded JPEG, pure RAW data).

Ah. Now I understand. I just checked. The DNG bug that was introduced in PL 6.1 also seems to be in PL 5.6. DxO is aware of the problem in 6.1, I wonder is they are aware of it in 5.6. If you export the affected DNG with their edits to a jpeg I believe you will see that the edits will be applied correctly. The problem appears to be s the way adjustments are displayed over DNG files while editing.

I see you also responded to the thread about this same problem in PhotoLab 6.1, and as I said, DxO is aware of it.


Ah! OK, hmm, that’s not my experience with Canon .CR2 and .CR3 files. All I can suggest is that you reinstall 5.5 then redownload and reinstall 5.6. Except it sounds like you don’t keep the installers so you can’t roll back. Perhaps if you raise this with DxO Support they will be able to help you roll back:

Yes, the export is “right” (full rez), but with no real way to see the modification I’m doing with the software, it’s close to impossible to export something usefull

1 Like