Photolab 5.6 Color rendering doesnt work

Im on windows 10. Updated to the latest photolab 5.6 version and when i select Neutral color, dxo portrait or Camera body colors, or dcp/icc profiles they do not change the color of the image.
This is using GRIII and GRIIIx dng raws.
This does work ok on Sony A7IV though…
Cant recall if this worked on version 5.5, probably did.
Where do i find photolab 5.5 download to test.

1 Like

You might find the app or an installer on a backup - if you have one…

Thanks but ive excluded my downloads folder from backups. :frowning:

Aargh…you might still be able to use the backup of the older version.

On Mac, I just copy the app back to a folder…but mileage on Win might be different.

Well that will teach me for not keeping a backup install file…

Ok so i tried this on an older GRI and there is an even bigger issue.
Photolab only displays the embedded jpg and also doesnt let you choose the other color profiles like the GRIII.
Its easy to tell its only using the embeded jpeg on gr1 as its only 640x424.
So this build is fairly broken…so far only found issues with dng files. (originals from camera)
Would really appreciate if dxo can link me to an earlier version that worked.

This issue sounds like it may be the same one as I reported in PL6.1.0 in this thread. If so it is being looked at by DxO.

1 Like


To do that, do you simply copy the App from the Applications folder?
Or does it need some other things (App parameters in Library…)?

yes, and I can put the app wherever I want. On my M1 MacBook Air, I’ve added to the Application folder a DxO Apps folder, into which I copy different versions of DPL with changed names like e.g. PhotoLab, - etc.

This might not necessarily work with Windows and its Registry though. Easy: just try it…after having made a backup.

Thanks @platypus
I’ll do that.