PhotoLab 5.1.3, extremely slow export?

I just updated to PhotoLab 5.1.3 (from 5.1.2), and suddenly it’s taking me much longer to export photos than it did previously. Before the update, my time to export a photo was in the 6 to 8 second range; now, it’s taking anywhere from a minute and ten seconds to a minute and a half. I’ve gone back and re-exported some of the same photos that I exported last week as a test, and confirmed that they are taking much longer now, with all of the same edits. Is anyone else experiencing this?

Here’s my software/hardware configuration:
DxO PhotoLab 5.1.3
Fuji X-T4 (uncompressed RAW)
MacBook Pro M1 Max with 32GB RAM

It’s the same 28 seconds for me (NAS → export DNG to local Mac folder) on 5.1.3

Fuji X-T3 (compressed raw / lossless)

My Mac (old):

MacBook Pro (15-inch, 2018)
12.3 (21E230)
2.9 GHz 6-Core Intel Core i9
32 GB 2400 MHz DDR4
Radeon Pro 560X

No slowdown on Intel iMac, macOS Big Sur.

@arcane93, have you checked what kind of noise reduction you’ve set? Switching NR (HD/Prime/DeepPRIME) can change processing times considerably.

If nothing else, does anyone know if there’s a way to downgrade back to 5.1.2? I’m not seeing any advantages in this new version so large as to be worth this problem.

Like I said, I tried re-exporting some photos that I had exported last week – exact same edits on the photos, and exact same export settings (JPEG 100%, no resizing or watermarks or anything like that). Some of them do have DeepPRIME enabled (Prime isn’t an option with Fuji files right now), but they did last week as well. Last week they exported in seconds, now it’s taking well over a minute for the same export.

If not everyone is seeing this issue, I wonder what specific factors might be causing problems here… could be the Fuji files, since Fuji support is still in beta (I can try some Canon files tonight after I get home from work and see if that makes a difference), or could be the M1, or…

I’ve got a set of about 600 photos that I was planning to export this weekend. Not looking forward to that taking 10-15 hours to complete. :frowning_face:

Have you tried exporting to DNG to observe if the process duration changes ?

Note when i mentioned no-changes, that was using my usual export to DNG. As I typically would finish off the edits in LR.

I’m not seeing any slow-down when exporting Panasonic RW2 images on my M1 Mac Mini.

Ok, so I tried a few different things, and I think I’ve determined that the problem is definitely in the Fuji RAW conversion.

I tried reinstalling PhotoLab, turning off my antivirus (as it’s the only other thing that has updated in the past week), changing the settings for DeepPRIME Acceleration from Apple Neural Engine to GPU… none of them made any big difference, exporting a Fuji X-T4 RAW file to JPG took about a minute and a half (the same files that had taken 6-8 seconds in the previous version of PhotoLab).

Then I loaded in some Canon 5D4 RAW files, did some intentionally heavy editing on them including DeepPRIME, ClearView Plus, Smart Lighting, etc. and exported them. They took 8-9 seconds each.

So the problem, it appears, is in the Fuji RAW conversion.

Hopefully someone from DxO will see this and they’ll get this fixed quickly, because this is pretty disappointing. The reason that I finally bought a copy of DxO PhotoLab was because of the addition of Fuji support, but this renders it nearly useless to me.

1 Like

Hi @arcane93,
First of all, welcome to the Forum!
Having said that, I’m sorry about the issue you’re facing with the latest update of PL.
But I have a ‘good’ news: I was able to reproduce your problem on the same machine (MBP M1 Max) and I can confirm your findings… With PL 5.1.3 I got 1’33" to export an X-T4 RAW file while with previous versions of PL I get a blazing-fast 8"…Definitely, we have a bug here!

The issue has been reported to our teams.
Thank you.


1 Like

Thanks for looking into this so quickly Steven! In the meantime, is there some way that I can downgrade back to PL 5.1.2 until the fix is released? I’ve got a set of 630 photos ready for export, but with this bug I calculate that it would take me over 15 hours to do that.

…easy, if you’ve got a backup of version 5.1.2 or its installer. Just replace the current DPL5 app with an older version that you find with time machine or whatever your backup tool provides…

Unfortunately, I don’t keep backups of my applications – normally I expect that I can just redownload them and reinstall them if necessary. Obviously that has backfired here. :man_facepalming:

You should never count on that. In general, most software publishers do not provide downloads of previous point updates of their current production software once a new point update is released. One important reason for that is version control to ensure that users can only download the one and only current version.


Under normal circumstances, I’m not even worried about going back to old versions. This one just hit at a particularly bad time, as I finished editing a large batch of photos from a trip that I’ve been working my way through for a while now. I guess it’s not really time sensitive, so if they can’t just provide me with a download of the old version it’s not too big a deal as long as it doesn’t take too long for them to issue a fix.

While we’re investigating (and fixing) the issue, if you don’t have any available backups, I suggest you to get in touch with our Customer Support to get a download link for the previous version…


A tip, always keep an at least one N-1 version in case if needed.
That’s what I do for most of my software except a few like DxO … I keep them all … maybe a little fetishist :rofl:

We confirm that the issue is reproduced with M1 Max but also just M1. We get the issue both with latest and previous versions of PL5, so it’s no use going back to an older PL. The issue appears in our tests on macOS 12.3 but NOT macOS 12.1. So a regression was introduced at some point by Apple.

If you haven’t upgraded macOS yet, it’s up to you to choose between this issue and the other improvements & security fixes brought by macOS 12.3.

If you have already upgraded and mainly process Fuji Xtrans images (other raw images, including Fuji Bayer images are not affected), we recommend to choose your GPU instead of Apple Neural Engine, even for the base M1 Macs with slowest GPU.

The issue is specific to M1 Macs, the usage of Apple Neural Engine, macOS 12.3 and DeepPRIME on Fuji XTrans images.


Ah… That probably explains it then. I did some editing in the time between when I updated to macOS 12.3 and when I updated to PL 5.1.3, but I might not have done (probably didn’t do?) any exports then.

Any idea if this is something you’ll be able to fix on your end, or is it going to be up to Apple to fix whatever happened in macOS?

Thanks for the tip about using the GPU instead of the Neural Engine. It still seems vaguely slower than it was before (a few seconds more), but it’s much, much better than it was, so I’m happy for now. I had tried that on my own before and it hadn’t worked – this time I exited out of PL and re-started it after switching the setting, not sure if that made the difference?

Is there any practical difference or difference in output when using the GPU vs the Neural Engine?

Any idea when we might see an M1-native build of PhotoLab? It’s one of the very few programs that I use which is still relying on the compatibility layer. Performance is good overall, but I can’t help but feel like it would be even better if it were native.

Thanks again!

It’ll depend on Apple’s answer, for now we don’t know.

Maybe ? :grin:

There may be differences if you check pixel values but nothing visible.

I can only give the official statement here:

1 Like

1 and a half year later I face the same problem with PL 5.13.0 an an Intel MacMini. I process Nikon NEF Files.

Any Ideas?