PhotoLab 4 unresponsive slow on Mac

Just downloaded and installed PhotoLab 4.2.1 for testing.
It takes about a minute after it responds to a click!
Activity Monitor shows 66% with 80 threads.
I killed it after some minutes and tried again. No change.
It’s now running for about one hour with the same unresponsiveness .
Unsable. :frowning:

macOS 11.2, i7@ 4Ghz, 32 GB
No Problems with other software on my system.

PhotoLab seems to scan my Volumes…
Console permanentely streams logs like these:

standard 20:17:52.876287+0200 DXOPhotoLab4 Resolve item D8FE6D21-5F6E-4E81-9E6D-E034EAB3BA7C, options: 768, list:
standard 20:17:52.877573+0200 DXOPhotoLab4 received:
fehler 20:17:52.877932+0200 DXOPhotoLab4 *** nodeWithURL:name:icon: Aliased node allocation didn’t succeed
fehler 20:17:52.877981+0200 DXOPhotoLab4 *** Unable to create Finder Place for item <SFLItem: 0x6000da8a6ba0> : 32bit-Programme.savedSearch - file:///Users/andreas/Library/Saved%%20Searches/32bit-Programme.savedSearch
standard 20:17:52.878074+0200 DXOPhotoLab4 Resolve item 35253656-9AF9-4B0F-ADF2-59EF38203894, options: 768, list:
standard 20:17:52.879462+0200 DXOPhotoLab4 received:
standard 20:17:52.880387+0200 DXOPhotoLab4 Resolve item B4CF73A5-207D-4538-9492-1D7771094379, options: 768, list:
standard 20:17:52.880686+0200 DXOPhotoLab4 received:
fehler 20:17:52.880768+0200 DXOPhotoLab4 *** LSCopyItemInfoForRef failed (-50)
standard 20:17:52.880891+0200 DXOPhotoLab4 Resolve item E8E7D072-FA44-4E8E-B2B1-017E3B012715, options: 768, list:

and so on…

I’d completely uninstall, restart, then redownload and reinstall. May not help, but worth a try.

I could solve the problem with deleting all my favorites from the Finder-Sidebar and recreating them.
No idea, what caused the problem - selecting each favorite in the finder worked…
What ever - it seems that Photolab was trying to resolve one or more of these favorite-entries and failed. This should be programmed more restrictively so that it will not be tried again and again…

Could it have been that PL did not have access to all of your folders?
Did you allow it to access Documents, Photos, Desktop etc under integrity and security settings in macOS?

1 Like