Photolab 4 hanging up processing first file, Big Sur

Hi, I am having problems running Photolab 4 on a 2019 MacBook Pro laptop using the latest update to Big Sur. The laptop is specced in excess of the minimum required to run Photolab 4.

Photolab 4 hangs when I try to process the first or second Raw file in a given folder. Any attempt to edit a Raw file(e.g. moving any slider) results in Photolab 4 being responsive for minutes to, less frequently, tens of minutes.

The problem occurs :

  1. whether or not the Raw file has previously been edited
  2. whether the folder sits on an external hard drive, an SD card, or on the laptop itself.
  3. whether I have granted Photolab 4 access to the Full Disk, or to more specific access e.g. to Removable Volumes, the Desktop Folder etc

If left alone Photolab 4 eventually becomes responsive again and if I export the partially processed image it will generally, but not always, then process subsequent files in that folder without again becoming unresponsive. Once I navigate to a different folder the same problem of PL4 being initially unresponsive repeats.

The problem developed only in the past month or so after in quick succession I had a Big Sur security update and an update to Photolab 4.

I have been in touch with DXO about this problem, and have deleted and reinstalled the latest version of Photolab 4 (v. 4.2.1) under their instructions. This did not correct the problems. I then created a new Admin-level user and Photolab 4 works correctly under this user.

I was wondering if anyone else has encountered this problem and, if so, was there a solution?

Thanks, Ian.

If PhotoLab works correctly under a new user account, the cause of your issues probably lies in one or more than one of the following: Database, cache, workspace, lens module or preference files. All of these are located in the Library folder of each user account and are created by PhotoLab when it is used for the first time on a new user, be it an admin or non-admin user.

I had similar issues a few years ago. A new user account can be the cure for ill effects that can build up over time, specially after beta testing and/or manual interference. I often tried to fix a corrupted user account (check/fix/reset rights) or switched to the new account, which meant to copy over the important stuff.

It’s a good idea to have separate user accounts for administration, work and testing. The downside to this is, that a few apps out there are not made to run properly in such a configuration without running the installer on each user. PhotoLab handles multiuser installations nicely according to what I’ve seen in the last few years.

Thanks for clarifying this Platypus.

I had something similar with Photolab 4 not showing the time/date from the exif data. I set up a new administrator account & everything worked fine, so I eventually backed up everything on the Mac & then reset it to factory settings & reinstalled everything from scratch. A long winded process but everything worked as it should after that. This was on Catalina. DXO said I had a corrupt user profile & that is why going back to factory settings corrected it.

Thanks for that info SteveL1. I seem to have sorted out my problem. I removed the Database files from the Library in my original user account my problem with Photolab hanging has disappeared (thanks to Platypus also for identifying this as a potential problem area).

At the same time I removed the lens modules from the Library folder and reinstalled them. This fixed another problem that I was experiencing: previously Nik 3 was not opening files when invoked within Photolab 4 (but the individual apps were working in standalone mode). This problem has now been fixed as well.