PhotoLab 4.1 - something whacky with the colour wheel

Just downloaded 4.1 and started to play with the colour wheel.

Here is the wheel before activating it but having selected the colour region I want to alter (the bill on the Pelican, which is a sort of orange.

Now, I click the pipette on the orange bill

Note the selected colour region changes to blue!!!

Anyone else see this?

Hmmm. So, I closed PL4.1, deleted the database, cache and .dop file for this image, reopened PL4.1 and everything is fine now


Dear Joanna,

I have also noticed it in 4.0.
For me I have created a workaround …I work with hiher zoom factor and/or with the pixel size of the pipette. And sometimes that doesn’t work and I have to increase pipette or choose another area wit little position move.
See the screens with a part of a boat. There is some colour cast in the region i worked

I hope the settings are also possible in MAC version :slight_smile:
settings pipette

Zooming didn’t change it for me.

I’ve just tried this on another computer on which I hadn’t yet reset the dop file or database.

I closed PL4.1

I copied the existing database files to a safe place.

I deleted the existing database files

I restarted PL4.1

Problem gone.

I closed PL4.1

I copied the newly created database files to a different safe place.

I deleted the newly created database files

I copied the original database files back from their safe place

Problem back again

@sgospodarenko could you have someone take a look at this?

OK, all sorts of weirdness going on.

How come the selected segment, the top row of dots, the pipette and the sliders all respond to the mouse when the TSL palette is not active?

This is definitely reproducible.

I use dop files rather than the database, which is why I can test by deleting and replacing it with impunity.

Before testing, make a copy of your database files.

I found I needed to delete both the dop file and the database between each test.

Then either delete the database to “cure” the problem or restore the original database to get the problem again.

I have gone through this procedure many times now and, by closing PL4.1, deleting the database and the dop file for the test image and restarting PL4.1, the problem goes away. Restoring the original database brings the problem back.

I don’t know if this is related: With PL 4.0.2 on Windows, I found a glitch when moving a control point - the test image shifts vertically while the mouse select button is pressed. This makes me wonder if the position of the pipette on the image is sometimes different on screen than what PhotoLab’s code sees. A small but measurable vertical shift would explain why blue was selected instead of orange or red.

Tech support told me that my glitch is understood and will be fixed “in a later update.” I haven’t had a chance to test 4.1 yet.

Unfortunately, there is no blue in the vicinity and when I try it on a different file, on a different computer, with a massive area of red, it still does it - until you delete the database and the dop file for the image in question.

Hmm. If not for what you just said about a “massive area of red,” I would have asked what color the picker thinks the lower half of the bird’s bill is. It looks slightly bluish to me - and then there’s the sky a bit further away.


Had you already selected a blue range on an earlier image. What I find with my Windows 10 installation of PL 4.1 is

  • (Assuming the colour picker is inactive) I activate the colour picker.
  • I choose an area of the image and select it - at this point the picker circle circle and HSL tool colour range reflect the last colour range I had selected, not the current one.
  • I click again on the same location in the image and the colour picker circle and HSL tool colour range now reflect the correct colour in the image.
    This seems to me to be a small bug in the HSL tool.

Just tried it on a black area with the pipette and it selected the blue color range

it works very well for me

Good morning, @Joanna,

Sure. Let me recommend you to tag either @SebinParis or @akarlovsky if the issue concerns the MAC platform.

Svetlana G.

Indeed, we have found an issue when a Crop is applied to the image, the picked zone will not match what you’re seeing on the image.
We have fixed so it will work as soon as we release a new version (we’ll try to do that soon, there are just other bugs we want to look into before that). In the meantime, what you can do is temporarily disable the Crop before using the picker, so it should work better in this case. If you have other geometric corrections, just disable them as well or they might have an influence as well.


Just to let you know it’s still a bit whacky on a virgin file. I get one sample on mouse down and another on mouse up with the pipette and that’s with a 25px pipette.

Same problem as mentioned above.
I work on an imac.

Just checked and it happens to my images as well. The solution was to reset the image settings. however, the issue might be when using 4K displays as the selection point (pixel) is tiny.