Photolab 3 photos not showing

I downloaded the trial of PL3 yesterday and it seemed to be working fine. Today I noticed in some of my picture folders that there is a virtual copy of every picture in the folder. I have never made a virtual copy of any of my pictures. So, I closed PL3 and opened PL2 and looked at the same folder. There was not a virtual copy of any of the pictures. So, I closed it and reopened PL3. Now it says there are no pictures in that folder. I closed PL3 and restarted my computer …(.I have Windows 10). After the restart I opened PL3 and it still says there are no pictures in that folder. I’ve checked other folders, and some have pictures but a lot of them say there are no pictures, but I know there are. Any idea what is wrong and how to fix it?

Hi Linda - - It’s probably best that you contact DxO Support … here.

John M

Besides the officious:

You where looking in those folders with PL2 sidecars in it and PL3 has updated the the sidecars when you looked in the folder creating a VC.(i think that’s what happend)

turn this off in PLV3 trail.

This prevent that PLV3 is updating sidecars from v2 to v3.
Turn in PLV2 temporaly load settings from sidecars off. (preventing to load corrupted sidecare info from v3)
go in explore back up by moving the sidecars in a subfolder inside your image folder. Your image folder is clean again only image files like jpg or rawfiles)
Then open the folder which had the issue in PLV2 and use:
To recreate the v2 based sidecars.

See if in plv3 (autoread on but auto safe sidecars off) your images returned.

Don’t forget to turn on auto read sidecars back again in PLV2 :wink:

Hope this helps.

1 Like

Thank you, I have done that now.

Thank you. I tried your suggestions but PL3 still doesn’t show my pictures in some folders. I discovered that the folders that show no images are the folders I opened in PL3 to work on them. The folders I hadn’t opened yet are fine. I also uninstalled PL3 and reinstalled it, but that didn’t work either.
I have contacted DXO support, so hopefully they can help.

maybe the database is corrupted somehow:
shutdown PLv3, check hidden items in explorer go to and delete:
C:\users\yourusername\appdata\roaming\dxo\dxo photolab 3\ database : photolab databasefile.

restart plv3 and the database is rebuild from scratch.


Ok, that worked! Thank you so much!

1 Like

Had the same issue today with PL3.2.0 4344.
Deleting the database scares me a bit. Renaming the actual picture folder in Windows Explorer worked for me. After that, PL was showing all the pictures in the folder.

However, renaming the folder inside PL did not fix the issue

Is there a way to rescan the ‘root’ folder of the picture library?

Stephan - - If you’re using Key Words as part of PL’s DAM features - then they are stored in the database. Otherwise, there is no problem in deleting the database file(s) - assuming you have sidecar/.dop files associated with all your images - PL will rebuild the database on an as-needed basis.
I do this on a regular basis.

John M