PhotoLab 3.0.3 installer blocked by Windows 10

While running PhotoLab 3 this morning, I noticed that a new update is available - 3.0.3. So I selected the option to download it and closed PhotoLab 3. When the download finished, I ran it - and Windows 10 blocked it as an unknown application to protect my PC. This is the first time I can recall a PhotoLab installation being interrupted like this, so I’m reluctant to continue with the installation. Is anyone else having this problem? Is there something wrong with the build or just with my download? Thanks for your help!

No problem here with Windows 10 1909 + Eset NOD32 + Emsisoft antimalware. Maybe a Windows firewall setting ?

It’s just a result of the fact that it’s a very new application. Microsoft did not know what it was yet. I also have incidents like yours when I install something very “fresh”.

Check the properties of the setup executable. It should have a ‘Digital Signatures’ tab.

If not the file is corrupted.

Look into the controlled folder access.

Thanks! I have controlled folder access turned off - I’ll look into it further.

The downloaded file info looks good. In the Properties window, there’s a note that says, “Security: This file came from another computer and might be blocked to help protect this computer.” There’s a checkbox here that allows unblocking. This the first time I’ve come across any of that.

I re-downloaded directly from my store account using another browser and got the same result. So I suppose it’s a Windows policy that’s being strictly enforced on my PC. Anyway, PL3.0.3 installed OK.

Learning never stops. :smile:

Here is detailed information on such cases, among other things. It may be useful:

1 Like

Exactly. You can still run the update by bypassing the warning. (Only do this with trusted apps like direct update/download from DxO!)

No issues here when I updated. I have Windows 10 Home version 1903 OS Build 18362.476