Photolab 2 uses a lot of memory and hangs frequently

It’s all in the title. I often get the beachball! Slow to open, slow to change menus, huge memory usage.
I have to qui all other apps. Indexing is terribly slow.
Not usable at he moment for my professional requirements.!

I am running Photolab2 on an iMac (Mojave, Retina 4K, 21.5-inch, 2017, 3 GHz Intel Core i5, 16 Go 2400 MHz DDR4
Photos on an external USB drive (No problem with LR or C1)

This probably won’t help you but I am running PL2 on a 2017 4k iMac and it runs perfectly. It is probably the fastest image processor on my system. No issues whatsoever. And my images are on an external drive of the spinning variety. Am on Mojave.

The same with me. I have been processing hundreds of raw images with PL2 on my MacBook Pro (High Sierra, i9, 32GB RAM) and have not had the slightest issue. No hangs, no spinning balls, no pauses of any kind. My images are also on an external usb drive, although that is an ssd.

What is the DPL cache setting you use? Try to change cache size (last tab in the settings) and see what it does.

How many images in your folder or project? I find DPL fairly laggy when I work on large folders, while Lightroom deals with them easily…

Hi. 37000 images.
I’ll have a look at he settings.

37‘000 image files in one folder?

No, I have several (many) folders and folders inside folders (RAW/Edit/select/rejected…)

How many images in the folder you actually work with?

Maybe I did not understand the question properly. I am working on a selection of images for a client, so there are 18 photos in that folder.

well, this should be running smoothly. You might want to quit dpl, delete its cache (using the finder) and try again. Or get in touch with DxO support for more hints.

Yes, this is what I figure, but it is painfully slow. I’ll do what you advise.
Happy new year :grinning:

Thank you, happy new year to you too

Sounds strange and should not happen. No idea what could cause this, if it is really only related to PL2. Only thing maybe that PL2 is not really compatible with Mojave. Running it myself on latest HighSierra on a 2017 iMac 5K, 27" 3,5GHz with 64GB RAM without any issues. Never crashing, no lags, besides waiting for updating preview when making changes. Photos are also on an external drive connected with USB.
As far as I know PL2 doesn’t install any extensions, but maybe its worth a try to start to safe mode and check if the problem still exist. Advantage of starting to safe mode ist also that system and font caches are automatically cleaned, and as part of the boot procedure the hard disk is verified and attempts made to repair issues with directories.

Thanks. I’ll try this and get back to the thread…

I have done what you advised. Very strange. In safe mode, the “viewer” is totally blank and does not show the selected image…

so it seems some involved extension is missing in safe mode PL needs. Anyways, go back to normal mode and check if its still crashing. Maybe starting to safe mode has fixed sth. Btw. I also had my first crash yesterday with PL. Did nothin special, poof it was gone. Since than ok and still not lagging or spinning wheel.

screen from my cpu usage

The CPU usage on your computer is much lower! I don’t know what the matter is with mine. How can I contact DXO support about this?

Opened DPL with a set of 60 files (1.3 GB on the volume), did a few changes to all images and let DPL settle so that CPU was low again. Here is what I get on my 27 in iMac (end of 2012) with 24 GB RAM:

After a few more changes and an additional set of images, memory usage changed, but not drastically, the increase in physical and private memory usages went up according to the increase of the number of images (roughly), virtual and shared memory changed but little.

Contact DxO support through this site:

When I look at your process values, I find that the ID (17412) is fairly high. Many things seem to run concurrently on your machine. Virtual memory seems high too.

Virtual memory stays below 6GB on my Mac, No matter whether I open 30 or 1639 files.

Hi there, I am getting exactly the same problem. No problems accessing my archived files on USB from my Macbook Air but just spinning ball time when I try it from my iMAC. I currently have a support call with Dxo open but haven’t solved the problem yet. Would be really interested to know of any solutions to this…