Photo Corrupted by Software

When loading a photo into the library, the colors and photo itself becomes insanely corrupted, I don’t even know what to call the problem. You can see on the attached how half of the image gets physically moved and a few the colors become fully saturated, obscuring the rest. In the camera and before PL does it’s processing the image is fine. And it is only happening on a few of the images that have very intense color (in this case pink). Shot with a Pentax K-1 M2, HD D FA 24-70 in raw.

Wow. That looks strange indeed.
I would say it’s related to data corruption but I can’t be sure.

Any chance you could link to a raw for us/me to download and take a look at?

it is very possible that it is a corruption of the raw file: for example during the copy on the memory card, or from the memory card to the hard disk. In this case, it would not affect the jpeg thumbnail embedded in the file, which is first displayed briefly in PhotoLab before it reads the raw part of the file.
Anyway PhotoLab cannot corrupt a raw file: it reads the file but does not write anything to the file.
It’s not the only possibility, but it seems quite possible to me.
As said above, the provision of a raw file concerned may help to understand the problem.

Looks like a case for

1 Like

This happens when the memory card has bad sectors.
Sometimes I encountered this problem when I worked as a reportage photographer.

1 Like

… and always reformat the memory card in the camera !

1 Like

The odd thing about the image is that it has actually now be fixed in PL, but now the same problem is occuring in different imageas, leading me to think that it may be a memory issue with my desktop computer. Very inconsistent.

I do, thanks for the confirmation.

@MikeCross I last experienced anything remotely like this way back in 2014 with JPG images taken with a newly purchased Lumix L7 but the image damage was permanent

although the thumbnail was fine. In this particular directory there were 2 such images out of 175. In a previous group 3 out of 157, all on the day of receipt of the new camera and all permanently damaged. Typically I automatically delete as part of the load process (although recovering “deleted” images immediately after such an operation is normally within the scope of most recovery software).

I believe I suspected the card and/or the card reader and I have come across a few other images (I believe) similarly damaged subsequently but the shutter count on that camera is 77,000 and the bulk of images taken on that camera are fine!?

I presume that you have tried the images with other software, e.g. FastRawViewer, running through the images as quickly as possible to see if you can catch the “gremlin” out, FastRawViewer has an option to use either the RAW or the embedded JPG so you can ensure that the RAW is being accessed and displayed!?

Computer memory problems are rare, in my experience, all my machines are home build (Win 10) and if the machine doesn’t like a particular memory combination the O/S is normally the first thing to start acting up or not acting at all, i.e. erratic or no boot up etc.!?

Overheating can cause problems …

Disk or SSD issues are a possibility but … Have you any monitoring software and is it complaining about the state or temperature of any drive?

Have you “played” with the hardware recently and using the standard I.T. response “Have you tried turning it off and back on”!

Have you … sorry this is a bit like an inquisition.


  1. Do not delete immediately after importing images from a card!

  2. Import a second copy if disk space is available (then delete from the card if space is at a premium or the logistics of loading are compromised by having multiple shoots on the same card)! Preferably load the second copy to an alternative drive if possible.

  3. If you have any comparison software then compare the two copies after loading and be prepared to repeat the comparison if any “corruption” occurs at any time!

  4. Review the images as quickly as possible using a photo manager that exercises/exorcises the RAW image itself and not just the embedded JPG, the idea of flicking through the images quickly is to see if it is possible to “induce” any “error”.

  5. Monitor the hardware for possible temperature issues

With a room temperature of 26 C my machine needs a vacuum to clean the heatsink, its basically idle while I am typing this!?!!

It is definitely not a raw file problem, as I gone back to raw files from 3+ years agoo and they are showing the same irregular, odd problems, and they weren’t in the past. In addition, everytime I open PL, different files have problems, and some files will actually correct themselves while processing. I down to it’s either a PL problem (this has only happened since I upgraded to 5.4) or a problem with my desktop computer.

Hi Michael,
did you change anything in your machine
or could it be due to hot temperatures (insufficient cooling)
or problems caused by your power supply?

How can a file correct itself during processing @sgospodarenko if a file is corrupt then it is corrupt and further processing can only compound the problem unless the image data is read again, which seems unlikely!?

Is the issue to do with the graphics output. i.e. the image is actually O.K. but the screen representation is becoming corrupted (by PL5.4.0 or the hardware)!?

Heavyweight graphics cards might put a higher and fluctuating load on the power supply!? Arguably a fault like this could occur if a graphics card or onboard graphics “glitched” and that could be power or temperature related or it could be graphics card memory related or …!!


@sgospodarenko has a problem like this been reported by others to save us wasting time thinking up “plausible” reasons when PL5.4.0 was actually changed in a way that might expose such a problem (whatever it is!)?

I find the “self” fixing issue to be “weird” because it doesn’t make any sense. @MikeCross if you process an image again does the problem occur again (if not always then sometimes) and is such an occurrence at a similar point?

There are a few factors we could try to eliminate.
Corruption is there - but in embedded jpg, raw or not at all in file. If so it’s due to file processing in memory on motherboard or graphics card.

I would run exiftool and extract the embedded preview from a few files and do it over a few times to see if the extracted images changed been extractions.

I would also process the raw files with some different programs on the same machine as well as a totally different one.

A short anecdote - I used to work at a large media corporation and we suffered a massive problem for our multi million photos and file archive.
We took it down and to rebuild drives and lost more files. Ran integrity checks and found errors everywhere.
Rebuild new drives and lost even more files.
Pretty much all files we read and wrote to new raids was lost even though they passed integrity checks the minute before.

In the end we found the root cause to the problem and was able to fix it. It was the memory on the raid controllers which was broken. No system check managed to find that but it meant everything read and written took a beating on that cluster.
Replaced the memory and everything was ok again. Accept for the already corrupted photos. They were lost for ever.

I had this exact problem too - it turned out that the new SSD I had just started using for my photo library was corrupted. The problem started slowly but gradually more images started showing up corrupted (similar to yours). Fortunately my online backup still had uncorrupted versions of the corrupted files.


could you share the file so we can test if the file is really corrupted.


I have the impression that we are talking about different things here.

  • images that occasionally display with errors
  • image files that have been damaged

We can get different kinds of issues:

  1. If files do not show any image, or show images with exactly the same errors in every application they are viewed with, the files might be damaged indeed.

  2. If files are displayed with occasional (and/or changing) errors in app “A”, but display nicely in apps “B”, “C” and “D”, the files seem to be okay, but app “A” is not.

  3. If files are displayed with occasional and/or changing errors in app “A”, “B”, “C” and “D”, the files might still be okay, but the underlying infrastructure (the PC) might be the problem.

@MikeCross , can you point out the kind of issue you’re getting?


I would like to supplement platypus’ great error analysis with questions about the operating system, the status of the version updates, and the graphics card with the corresponding driver.
Since the error only occurs with pink colours, there is a small chance that it could also be an error in the graphics card driver.

Happy testing

edit: and all those who read along here could either enter the corresponding technical data in their profile or, in the case of technical problems, write them in the post.

1 Like

Yes exactly. This also happened to me once, but with the HDD. For a couple of days I could not understand whether it was a card or a disk, it turned out to be both. A very unpleasant thing. :slightly_frowning_face:
There is still no stable data storage technology, although it is possible to carve data in stone :grin:

Correct…and we have to remember that a NAS with a raid does not replace a solid backup/recovery strategy.
I first save from SD card to my local SSD for culling
Second I save from SSD to NAS with raid
Third I backup the files from NAS to external backup SSD1
Up to this point, I still have the data on the SSD, which I no longer put in the camera but keep separately.
Every month I synchronise SSD1 with external backup SSD2 which is placed to another location than SSD1
After 3 month or so I will use the SD Card for new session

For the moment I don’t use any cloud solution for one more backup, but I’m thinking about.

Any suggestions welcome

Thanks everyone for the advice, and you were right on. Problem was with my RAID, there were errors on the drive. Windows fixed those and now all is good. Appreciate all the help and advice. Luckily looks like nothing was permanently corrupted, only when it was read.