Photo Browser Not Displaying All Images

The Photo Library image browser is not displaying all the images in the folder. This previously worked fine. In fact, there are even .dop files that do not display or open in PL. The images appear in and open with Photoshop.
For example, the PL4 image browser displays 3 images in the selected folder but it actually contains 70 images. I notice a small red cross is displayed. Any ideas?

Good morning!

“Red cross” means that there is an issue either in the sidecar or most probably in you DB.

Could you, please, provide us with your log? ( Log files – %UserProfile%\Documents\DxO PhotoLab 4 logs)

Please, archive them and attach here.

Thank you
Svetlana G.

DopCor.0.txt (64.6 KB) DopCor.1.txt (158.3 KB) DopCor.2.txt (32.8 KB) DopCor.3.txt (28.1 KB) DopCor.4.txt (32.4 KB) DopCor.5.txt (192.3 KB) DopCor.6.txt (166.5 KB) DopCor.txt (34.1 KB) DxO.PhotoLab.0.txt (411.4 KB) DxO.PhotoLab.1.txt (1007.2 KB) DxO.PhotoLab.2.txt (40.0 KB) DxO.PhotoLab.3.txt (153.4 KB) DxO.PhotoLab.4.txt (77.6 KB) DxO.PhotoLab.5.txt (560.0 KB) DxO.PhotoLab.6.txt (1.4 MB) DxO.PhotoLab.txt (3.3 MB)

Thank you. We will investigate the issue.

Svetlana G.

Thanks. I have uninstalled and reinstalled DxO PL4 but it didn’t change anything.

Hopefully get some results soon. There are many photos I cannot process. :frowning:

Contacted Support regarding this problem. They suggested I create a copy of all files and folders to test if DxO PL could see the copies. It did. “This is a rarely occurring problem on some PC’s that our developers are investigating. It is suspected that the problem might be related to how the computer is configured. For now, the recommendation is to move the files from the file folder that is not working properly to the new folder until a resolution can be found.” SOLVED (sort of…) for the time being. It means I now have two folders containing all my images. That’s double the file space. The original folder for Photoshop and image library management and the other for working in DxO PL.

Update to has not fixed the issue.

I still have to run a duplicate folder of all my images.

As a Windows 10 user I’ve had the same problem and it’s very annoying. This is not the first time it’s been reported. I’ve been using PL4 Elite since version 2, and am currently at HArd to know when this defect crept into PL.

  1. Has this issue been reported for Mac user or is it only a Windows issue?
  2. On June 30th you kindly responded, “Thank you. We will investigate the issue”. It’s now August 14th.
  3. Is there an open ticket on this defect?
    3.a If yes, can you please provide the the ticket number?
    3.c I’ll work with the support team going forward.

Dear @Urbana-Gold,

The issue itself is not fixed as it’s rather complicated. But the users who addressed his/her issue to the support is provided with the temporary workaround as far as I know.

So, please, address your issue to

Svetlana G.

Thank you @sgospodarenko
I created the below support ticket. NOTE 4.3 below

  1. Bottom of Viewer window displays the following 2 scenarios:
    1.1 “5 of 26 images” with a “Red x” ( n of N images)
    1.2 “0 images” with a “Red x”

  2. Window’s “File Explorer” displays all raw, .jpg, .and dop files.
    [ All raw files are Samsung, all have extension ".SRW ]

  3. Attached: DxO.PhotoLab.txt from scenario 1.2 above.

  4. Believing this ‘could’ be a DB issue:
    4.1 I closed PL4.
    4.2 I renamed file C:\Users(my-user-name)\AppData\Roaming\DxO\DxO PhotoLab 4\Database\PhotoLab.db to PhotoLab.db.Orig
    **4.3 :grinning:STARTED PL4, AND ALL MY IMAGES ARE DISPLAYED :grinning:

  5. Notes:
    5.1 All log files, crash files also reside on C: drive
    C:\Users(my-usr-name)\Documents\DxO PhotoLab 4 logs
    C:\Users\my-usr-name\Documents\DxO PhotoLab 4 crashes
    5.2: My C Drive is Solid State Drive (SSD)
    Total 237GB
    Used 128GB
    Free 108GB
    5.3: I De-Frag the C Drive (I mention this knowing Mac does not require de-frag)
    5.4 All my photos reside on my D: Drive (HDD)
    Total 931GB
    Used 583GB
    Free 348GB
    5.5 I De-Frag the D Drive
    5.6 I did notice a PL2 DB on D drive:
    D:\Users(my-usr-name)\AppData\Roaming\DxO\DxO PhotoLab 2\Database\PhotoLab.db

  6. In summary:
    6.1 I still have PhotoLab.db.Orig. Cannot attach it, get error message " The upload took too long, connection was lost"
    6.2 Using the new .db file, I have not performed an exhaled test of my photos e.g. all my edits to all my raw files.
    6.3 Obviously I’m not sure why rebuilding the DB from scratch displays all my photos; as mentioned I need to validate my raw file edits.
    6.4 Please pass on all thought, suggestion etc.

  • Yep, this is exactly the sign that your DB is corrupted. And as you have already created the support ticket you will be guided there with the procedure.
  • Could you, please, try to archive it first and then attach?

Svetlana G.

Hello Svetlana, (21.9 MB)

Thank you, GREAT suggestion, your help is greatly appreciated.

Best Regards
Lawrence Norman

Good morning @Urbana-Gold ,

Thank you for the db, but you should attach it to your support ticket :slightly_smiling_face:
It will be useful for the developer who will be working on it.

Svetlana G.

Hello Svetlana ,
I created the ticket, but never received a ticket confirmation from support. (I also looked in Junk)

Lawrence Norman

Good morning Lawrence,

Please, wait a bit they should get in touch soon.

Svetlana G.

I used Photoshop to backup the original photo folder and then restored it to a new HDD. PL4 so far seems to reading all photos in the new restored location. I will now use the new folder and have deleted the original photo folder and the copy I was using for PL4.

1 Like

I have the same problem now with PL6. I have two directories where I get the dreaded White X on Red circle next to the file number. It does not load all files. I raised a support ticket ( but I have had no response to it yet. I do not want to lose the edits I have done on the files I cannot load or those in the rest of those directories, which took many hours. Is there a way I can sort this without having to do re-edits? If I duplicate the directory and will probably see all the files but lose the edits in the files I cannot see currently. Is there a way I can ‘fix’ the corrupted database? Any help welcome - this is making me nervous as I have +30,000 edits in my database and if I can get a corruption twice in short order after upgrading to PL6 then I am worried it could happen again. Never had this problem with PL2,3,4,5.

Did you ever get a resolution to this? I just started having this problem as well. I’m new to PhotoLab and I’ve now done a ton of keyword/rating/tagging and was just getting ready to start editing 15 yrs worth of photos but this issue is making it impossible. I submitted a “tech support: troubleshooting” ticket 3 business days ago and haven’t heard anything.

Hi - no I didn’t. I had an exchange with a support person, and they asked for dumps/logs etc, but by then the new version of PL6 had arrived which seemed to stabilise it so I gave up trying to figure it out. I had two directories with the issue, and what I did was to move the files it didn’t load to another directory (mine are by date so I created a [date]b directory, and then I could see the rest (with edits) in the old directory, and the ones I moved I had to re-edit in the new directory. I had approx 20 re-edits to do.

What I am now doing going forward is to a) backup the database more frequently - so I can restore mor, and b) once I’ve done the majority of edits in a directory, I export the edit info to the .DOP sidecar files for those Raw file I’ve edited (using the filter function to find then in the catalogue). Then, if I have a future database corruption issue I can import edits from the .DOP files again. You can also switch on DOP files permanently which will help if similar issue.

I have had a perfectly stable PL6 since the 2nd build post the PL6 upgrade, so no further issues. But without use of sidecar files you are dependent on the database holding up!