Perspective Efex taking ages


I’m using the Nik Collection (currently 4.3.0) for ages in combination with Adobe Photoshop (currently 23.0.2). Why? Because I’m loving it.

Probably the item I used the most is the Perspective Efex (which doesn’t have an own feature-forum over here, which I think is a bit strange).

But since a couple of weeks I notice that Perspective Efex takes a very, very long time to adjust the image. The Preview and Apply buttons are quick as the used to be, but whenever I want to Save the image (and going back to Photoshop) it now takes ages. It used to be a couple of seconds but since a couple of weeks it now takes about 5 minutes per image.

I already tried going back to an older version (3.0.8) and even tried an older Photoshop version, but no result. I disabled the GPU in Photoshop, no result.

Very strange as it always used to work. Somebody have an idea or similar problems?

Which platform are you using, MacOS or WinOS? Has there been recent updates to your OS or drivers? The version you are using: 4.3.0 has been updated to 4.3.2. Have you tried the new version?

I’m running Win10, and install all of their updates. Not upgraded to 4.32. yet.

Could be that a Windows-update caused the problem as it used to function 100%.

Strange thing is, that I searched the internet a lot, but couldn’t find 1 person with the same problem.

It sounds to me like something has changed within your system. I would try updating to 4.3.2 and see if that helps, it couldn’t hurt.

I do as well have problems with the perspective-tool but in PL5. Opened a ticket #317239 but it writes page is not available and no answer yet from support.

1 Like

@Fotoguido , do you have a similar problem as I have? So that it takes minutes (in stead of seconds) to perform the action. Whilst, when disconnected to the internet, it takes seconds as it should do.

No, to save perspective changes did simly not work a few times and then PL5 crashed and produced a dump. Sent then and now waiting for reply.

Hi Klaus, it is probably best for you to do as @Fotoguido did and submit a support request to Good luck!


my laptop did an automatic windows update and the problem with non reacting perspective-tool is now gone. Possibly a driver hickup. Could be a good idea to doublecheck on your side, could be a similar solution. Cheers.