OpenCL-support for Prime


In the past, I had a Radeon RX570 installed in my computer and constantly had problems with OpenCL or graphics acceleration enabled. This has expressed itself, among other things, in display errors of the interface (missing icons), or, with OpenCL enabled, in crashes of the AMD graphics driver when converting images.
Therefore, I have so far performed the conversion without OpenCL - purely with the computing power of the AMD Ryzen 3900x.
Over the weekend, I bought an NVidia RTX 3070 and was thrilled to see that the conversion of DeepPrime images is now up to 8x faster than via the CPU.
However, I also noticed that this acceleration is apparently only used with DeepPrime, but not with Prime.
Is there a reason for this?

Cheers, Tabaluga73

1 Like

PRIME was never designed to be used with a graphics card’s GPU. Probably the only reason that PRIME still exists as a feature is for those users who do not have a graphics card with a GPU that supports DeepPRIME processing.

Practically no one on this site uses PRIME anymore if they don’t have to. DeepPrime is far superior to PRIME in every way. I myself have not used PRIME once since shortly after DeepPRIME was implemented in PhotoLab 4.



what Grafikcard do I need for the GPU Acceleration in my Mac 5.1 ? I have a RX580 and this Card cannot support the DeepPRIME Export

I am not a Mac user but I thought the RX 580 supported DeepPRIME processing. Perhaps one of our many knowledgeable Mac users will be able to assist you.


The RX580 supports DeepPrime just fine. You have to be on at least Big Sur (which theoretically is not supported). It also helps to enable the RX580 acceleration via OpenCore. Not sure if it’s necessary for DeepPrime as I always had acceleration enabled for both my RX580 and Radeon VII.

1 Like

Ah realy ? Iam on a MacPr 5.1 with 12.5 and Radeon AMD saphire RX 580 and OpenCore Legacy Patcher And DeepPRIME is not supported. Can you give me some Tips ?

Have you confirmed that PhotoLab’s settings indicate that you want to use either your card specifically set to automatically select a card rather than set to use the CPU instead? If it’s set at CPU only that is one possible reason that your card is not being utilized. Those are the settings that are available in the Windows version. I can’t be certain that they’re identical in the Mac version but you should at least check.


the setting will be found here

I’m on a MBAir so no gpu to select, but take a look

Good luck


Thanks Mark, than I will proceed with DeepPrime only.

Thought that Prime might be less “aggresive” than DeepPrime and thus having less impact on the picture-quality / -originality. But understood that Prime just remains for non-GPU-supported platforms.

Hm, as written above, I had huge problems with my RX570. I opened several tickets to clarify why the surface of DXO missed several icons as soon as GPU-acceleration was selected. See picture attached - unfortunately only in German but the arrows indicating the missing icons.

The support-team proposed to disable GPU-acceleration in the config-file:

  <setting name="EnableWpfGpuAcceleration" serializeAs="String">

That worked fine for me, but slowed down the processing of the images tremendously.

Before changing to the RTX3070 I once more tried to export my images via GPU support, to be able to compare the performance of the RX570 with the RTX3070. After one picture the export was aborded and the AMD-driver popped up with a crash notice…

That was once more underlining that my decision to change the graphic-card was correct. Whether AMD or DXO is “liable” for this behaviour, I do not know. I just know that this problem exists since several years and could not be properly solved for me.

Hi Holger,
I’m really not an expert on graphics cards, but once Alec talks about an RX580 but you talk about a 570. No one talks about the version of the drivers used and any tweak settings, nor about the version of the operating system incl. patches/updates.

Perhaps this should be taken into account and possibly also stated in the posts so that other members can perhaps join in the discussion on a technical basis.
This is an apples and oranges comparison. :innocent:


Hi Günter,

fair point. As I wrote, I was discovering that issue over a couple of years. I was using several AMD Radeon drivers, mainly the latest versions, when they were issued. The operation software was win10 and is now win11 - up-to-date with the latest patches. I did not use any special tweak settings.

It is quite interesting that a switch of the graphic card solved all the issues I had over years with all the different driver- and DXO-versions. It seems that somewhere there might be a bug, but this is not up to me to specify.

My only tip is that our “friends” at DxO should have supported Mojave which was the last OS for the Mac Pro. Instead, DxO is captured by its young programmers who as naive youngsters only deign to work with the latest technology.

Consequence – I no longer recommend DxO software to others or advocate for PhotoLab as much as I like what PhotoLab can do for high ISO photos. I’m stuck using an M1 Max now that I never wanted – my own decision to choose PhotoLab years ago cost me €4000 this year not including software costs. While I had PhotoLab 5 working under 5,1 on Big Sur, the pain point on maintaining a stable of Mac Pros on an unsupported OS was enough to push me to go back to a single computer. I could have kept them all on Mojave for another year or two (when I would have been ready to upgrade) were it not for PhotoLab.

That the long answer – the short answer is no, I can’t troubleshoot Mac 5,1 issues now as I’m not using it any more. I didn’t have any issues at the time apart from how time consuming it is to run a computer on an OS for which there is no official support. The forum does have lots of hands on deck who may help you troubleshoot your situation, if you’ve taken the time to read and research before asking for help.

If I had to do it all over again, I would have moved to Linux fifteen years ago and would be using RAWtherapee instead. At this point in my life, spending years acquiring expertise in new OS and giving up all the software I know would be a poor choice. Back then, I was running a rapidly growing company and didn’t have any free time, hence I very reluctantly didn’t switch. But I didn’t know all the ill and disrespect for its users Apple had in store for us. Steve Jobs was still running the ship and there was no inkling that he’d be leaving both Apple and the world soon. Hindsight is alway 20-20.

The young should flee commercial OS while you can, if you value your privacy and wish to retain any control over your digital environment.