Not able to add Keywords in Elite

I just installed PL3 for windows - Elite version and I am not able to add keywords in the Meta area. All I see is info about image and provision to add Author and Copyright, but no button or link to add keywords.

I have already tried reinstalling PL3 and have confirmed no prior version of PL exist on my computer.


Hello Loren,

Right now editing of keywords in Windows version is impossible (will be delivered in PL3.1). For now you can see the keyword panel when the images already have some keywords:


If the image does not have any keyword - the panel is hidden.

Svetlana G.

1 Like

Svetlana, keywords in which IPTC field?

Hello Ralf,

And keywords are also read from XMP as you know.

P.S. Sorry Ralf, I was mistaken, for now only XMP data is read.

Svetlana G.

1 Like

Ok. So only the “keywords” field.

At the moment I save and change all IPTC data with Geosetter (uses exiftool) directly in the RAW files and after that start PhotoLab. I don’t need keywords in any XMP or DOP file or in a dedicated database that can only be used by one program. But it would be nice if I could enter some keywords or descriptions in an image while editing it in PhotoLab. I have not tried out yet what happens, if I open such an image additionally in Geosetter (at the same time).

Dear Svetlana,

Probably the phenomenon related to the Windows version of PL v3 only, but I still unable to see any Metadata detail in my system. The screenshot you published above with EXIFtool app, seems shows a JPG file IPTC content. If I understand well, PL v3 is able to read and record the keywords from JPG files. Is it correct ?
Testing the feature I took a JPG image made in 2013. It has no any IPTC data. Open PL v3 and there were no keywords. Correct.

  1. Added 3 keywords as Tower, Wien, 2013 with IrfanView.
  2. Open PL and see the Metadata tool content and later the pop-up display window over the thumbnails. There were no sign about the changes.
  3. Open the file with EXIFtool app, where the keywords were displayed correctly.
  4. Furthermore I set in the Preferences to Write the XMP file and generate .dop sidecar files.
  5. Made some modifications on the image and Export a resized JPG file to a different folder.
  6. The generated sidecar file did not include any of the keywords and the .xmp file was not generated neither to source nor to the target folder. The exported JPG file still included the original file keyword contents.
  7. Finally, I went to Adobe Bridge app. and added a 4th parameter to IPTC details, almost randomly to ‘Bi-line Title=11’.
  8. Open the same folder in PL v3, there was change in the Metadata content handling. The 3 keywords became visible in PL. Mystery.
  9. Generating a separate .xmp file to the same image RAW file version by Adobe Bridge, the 3 keywords also became visible in PL immediately.
  10. After the 2 images show the Keywords I wrote the Wien keyword to the PhotoLibrary / Search field. The result was 1 image only ( the JPG file ). I think there is still some random effect in the keyword handling.
    If you need, I can add the corresponding screen shots to the report to identify the stages.
    Anyhow, the EXIFtool is able to show the embedded content in the JPG file format only, the RAW file attached .XMP content is neglected.

I think the keyword handling ( add to a virgin file, edit, delete is missing ) is not yet suitable to use PL as a DAMM application.

Take care


1 Like

Sorry Endre,

It was my mistake (I danced faster than music :frowning: ), for now we read only XMP (embedded or not) and IrfanView writes a pure IPTC data, while Bridge, for example, adds XMP data as well and this is why you could see all the keywords in PL after adding additional one in Adobe Bridge. IPTC is in plans.

  • We are planning to do that in PL3.1.

Svetlana G.

1 Like

Svetlana, I have just tried to add some keywords. I could not do it in IrfanView. It does not allow me to save keywords in the RAW file. But GeoSetter (Exiftool) does. Without any XMP file. After that these keywords appeared in the keywords field in PL3. So I think you are on a good way. But I did not edit the file while PL3 was open. Maybe that will be my next test. :slight_smile:

1 Like

Getting back into my photography after a couple of years! Been trying to get the keywords up - ah, next release… :slightly_smiling_face: Any thoughts on importing from Lightroom? I guess that will require reading specific fields from within the Lightroom database. Anyone know whose database they use, I’ll go look for a client and see what I can find out…?


@a1collet, keywords that are added in Lightroom’s keyword tool show up in DPL, at least on my Mac.

Thanks, am using windows. Have to update my Macbook and give it a try

Same on Windows :slight_smile: . The only difference for now - you can’t add/remove the keywords inside PL.

Svetlana G.

I understand the ability to add and edit keywords for Windows version will be available in a future update. Can you tell us when?

Yep, it’s planned for December.

Svetlana G.

Thank you, looking forward to the update.

1 Like