Non Destructive Edits appears not to be working from PL4

Encounter the following situation on Mac mini M1 (2020), Big Sur 11.4:

  1. Export TIFF to Silver Efex Pro for conversion and edit.
  2. In Silver Efex Pro check that Non-Destructive Edits checkbox is checked.
  3. Select a preset and make edits.
  4. Click Apply and file is saved with change.
    (Up to this point all is well.)
  5. Look and the photo and see I want to make one more edit.
  6. Send the photo back to Silver Efex Pro by hit the Nik Collection button, changing the setting to “Export selected file without processing”, and click to send back to Silver Efex Pro.
  7. When the file appears in Silver Efex Pro it is set back to the default settings of Neutral and no edits from the previous editing in Silver Efex Pro are present. That’s the problem.

Edit: Tested more and see that some of the settings are being set correctly. However, the Filter Color, the Film Type, and the Toning settings are what I see as being the settings being set to the Neutral default settings. There may be others but I did not check every slider setting.

I have tried this multiple times and gotten the same results. Before I report this to Customer Support I wanted to see if anyone else had encountered this problem. Or, if this is a known problem that I missed hearing about let me know that also. Thanks.


Have you verified the size of the files? File size is about twice the size of files that have been saved without the non-destructive setting.

Sending a colour image to Silver Efex and saving the result should make it possible to regain the colour image sent to SEP in the first place. I’ve never tried it though because of the gigantic file sizes of multipage 16 bit tiff files…

The file sizes I got this morning were when saving the file with the Non Destructive box checked was 233.7mb. and with the Non Destructive box not checked was 116.9.

Again the Filter Color, File Type, and Toning settings were not carried over with the Non Destructive box checked. So, there is consistently a loss of data. I’ll go ahead and file a report of the issue with Customer Support later today.

To be clear I am not trying to reverse the image to its color state. I am just expecting the Non Destructive copy to be opened a second time in Silver Efex Pro and see the settings I originally made and modify them. What I am seeing is that it not all settings are being retained.


Maybe that is exactly what the checkbox is meant to provide. I’m not sure what the non-destructive stuff really does because I don’t use it (I always keep the original) - but here’s what DxO saying about it:

Right. Those are the steps I am taking and the result is that not all the data is being maintained. I’ll put in a ticket later today.


Hi Marvin,

It sounds like you’re using Nik Collection/Silver Efex Pro with PhotoLab - - in which case, there’s another way to be able to restart edits for an image in SEP … See here for details - It’s not an automated process, but I find it works well (for me).

John M

Appreciate the information John-M. I’ll get the problem logged to customer support. I’d like Silver Efex Pro 3 to do what it was advertised to do regarding saving selections.

Updated: Was not able to file with Customer Support. Encountering errors on the web site trying to switch back to my account to get information required of when I bought Nik Collection and how much I paid for it to complete a customer support ticket. I feel this is not the same quality company I have been dealing with since Optics Pro 8.


Hope you can get that sorted out, Marvin. I’ve always found DxO to be genuine in their attempts to provide good support - - perhaps (technical) problems on their site is hindering that. I suggest you retry.


New ProPhoto 6 Elite user here. I was searching around for a solution to this issue and came up with this thread but otherwise empty handed.

I couldn’t figure out how to makde the “nonm-desttructible” Silver EFEX option to work either. So what I’m doing now is saving a preset in Silver EFEX with the image name (for me YYYYMMDD-nnnn where nnnn is the frame number) when all edits are done. Then, when I pull up that image in Silver EFEX, regardless if plug-in or stand-alone, the first thing I do is apply the saved preset.

It’s a pain in the butt to do it this way but it works and, since I no longer check the “non-destructible” checkbox I have a smaller image file. Not worried about disk space - just faster when loading the smaller file on my antiquated iMac.

I do wish the “non-destructible” feature worked though. I’m saving my pennies for a new Mac and would love to have a single click option once I have a faster Mac.

If anyone has faced the same issue since Jul 2021 (previous post on this thread) and gotten the “non-destructible” feature to work, please share! Thanks…

Apparently when the “Nik Collection” is clicked PL makes a finished copy of the RAW source image and passes that copy to the Nik app selected. In the case of a TIFF created through SEFEX the same thing happens: a copy of the >finished< image is made and passed to the Nik app selected. But the finished image copy does not include the non-destructible information.

It would be nice to have an option to pass the source file “as is” to the selected Nik Collection app. I will add this request to the suggestion list.

Passing an existing RGB source file to a Nik app is possible, but must be set somewhat clumsily in the Nik settings. If the source is a raw file, it can’t be processed in Nik directly, it has to be exported as JPEG or TIFF beforehand.

@platypus: A big THANK YOU! for pointing me in the right direction. True getting to the option in Nik settings is a bit clumsy… but it’s a lot better than the jumping back and forth between PL and SEFEX I was doing. Thanks again…

1 Like

Did you ever try to pull your Nik standalone app / a link on the desktop
and simply drop your jpg/tif-file onto it?

( tried it in Windows with a link and Nik opened … )

@Wolfgang : Thanks for the tip! I dropped an SEFEX TIFF file on the SEFEX icon when the app was closed. Sure enough SEFEX opened and immediately loaded the image file. So yes, that method works in Mac OS as well.

FWIW I for a lot of reasons others on this forum may have already stated I am replacing LrC and Ps with DXO PhotoLab 6 Elite and Affinity Photo 2. There are plenty of learning to be had and I am thankful there is a robust forum for DXO products. I have a current project requiring I work in InDesign but once that is done I will replace it with Affinity Publisher and leave the Adobe workspace entirely. TMI perhaps but so far it’s been a delightful journey.

Thanks again to you and platypus for your quick and helpful guidance.