No update of metadata in PL3 (Windows version) after editing external

After writing my personal metadata into the RAW files with Geosetter I opened the images in PL3 and started working with them, when I saw a mistake in the copyright field in all my images.

I closed PL3 and started Geosetter again to correct the mistake.

After relaunching PL3 then again it showed the old entry in this data field. A control of the result in other programs like IrfanView or GeoSetter proved that the entry had been changed correctly. Only PL3 did not update it and showed the old one. That’s not good. Please fix this mistake!

Windows 10x64, DxO PhotoLab v3.0.2 Build 4266 (Elite)

Would it not be better not to modify the raw file ?

I guess that you have to refresh the folder in DPL to get the updates.
Otherwise the database keeps the old value.

Of course I have done that. I have closed and reopened PL3 and I have tried to refresh the folder by pressing F5. No change.
And I had always data in the EXIF- and the IPTC-part of my images. These RAW files are like the negatives of old analog films. So if all necessary data are in the RAW file I can export them to any format or restore it to the source file.
I did never see this problem before.

Hello @Ralf_Brinkmann,

That’s not a mistake. We treat input files as immutable and directly taken from the camera so we do not track their possible changes. To solve your issue you should:

  1. Copy your files into some temporary folder.
  2. Launch DPL 3 and remove the images from your working folder.
  3. Close DPL 3 and copy your images from the temporary folder to the working folder.
  4. Launch DPL 3 again and make sure DPL 3 reads everything as expected.
  5. Remove the backup folder with its content.

Pay attention we cannot guarantee that DPL 3 can always handle input images after their modification by third-part software.


I’ve tested again this function with DPL v3 on Mac Mojave.
I had worked on a folder in which I can see keywords on images. These keywords have been written directly into the raw (Nikon NEF) files with Photo Supreme.
I close DPL.
I open Photo Supreme and add keywords to some images.
I close PS and open DPL.
And there I see that all added keywords are visible in images without doing anything. So my mistake when I written above that a folder refresh should be done as it is not necessary.

As Mac version has already capability to add keywords directly into DPL, perhaps this has something to do with, and that it could come to Windows version soon.

But it may also depends on how Geosetter is writing keywords in your raw files, using IPTC model or XMP model. Only the last case is available into DPL.

In an older version of PL3 I also tried to add some keywords just for testing. I did it with Geosetter or IrfanView, I’m not sure.
First PL3 (Windows version) showed no keywords, because there were none. After adding them external PL3 showed the keywords. And later, after deleting them external, PL3 updated the view again and didn’t show keywords anymore.
Why should PL3 not do that with other IPTC data fields? I don’t understand the sense.
And the funny thing is: I can edit this Copyright entry in PL3. Even though this is the Windows version.

Edit in windows is ok but adding is not possible for time being.