Nik4 no longer works with Captuer One Pro 21 like previous version

I was excited about the new NIK4 features and downloaded the trial version straight away, but I immediately discovered it no longer works with Capture One Pro (C1P) like my previous Nik Collection and that I’m NOT able to SAVE back to C1P.

Even though DXO doesn’t seem to cover C1P officially as part of their supported plugins, I never had any issues using their previous version straight out of C1P, which I still use occasionally, so I expected the newer version to work just as seamlessly, but sadly this no longer appears to be the case :cry:

Oddly enough I’m able to add & open NIK4 as a plugin in C1P and it does pass the images along to the chosen NIK4 tool e.g. Silver Efex Pro as before, but after making my selections/tweaks and saving my changes it simply passes me back to C1P without any changes applied, rendering the new NIK4 utterly useless IMO by comparison to the previously working version .

I could do a round trip via Affinity Photo (AP), which does work as expected and there is not issues passing images between NIK4 > AP > CP1 but this is just way too tedious as the majority of my edits are done in C1P and hardly ever requiring AP.

Every year more & more users of Lightroom (LR) move to Capture One Pro
Every year more & more users of Photoshop (PS) choose Affinity Photo

LR & PS are no longer the only top Photography toolset like they used to be, this is a fact.

C1P & AP are fast becoming the new de facto replacements and DXO is really needs to come to terms with this or you will continue alienating potential customers like me.

PS I immediately uninstalled the trial version which looked so promising

Welcome to the forum Michael,

I think you hit the nail on the head.

DxO should take this as a wake up call and make a bigtime push to position themselves to fill the gap, to be the next go to step in RAW photo editing. The software PL, FilmPack and ViewPoint need to be unified into one program rather than being sold as addons requiring another purchase. The ability to keep the image within PL without having make in interim Tiff is also a must and it also goes without saying that everything the Nik Collection can do should also be integrated into PL’s basic tools.

DxO/Nik 4 do not officially support C1 as you mentioned correctly.

IMO, the easiest way to use Nik 4 in this case would be to export to TIFF and use the Nik apps standalone. After you’ve done your tweaks, synchronise the folder with the image(s) and you’re done.

You’re still in trial, which means that you can uninstall Nik 4 and re-Install your previous Nik…

1 Like

I spotted the same thing, Silver Efex is stopping during the Processing Image phase (i.e. the progress bar does not complete) and doesn’t even attempt to save the TIF. This looks like a bug to me, but DxO support simply report that C1 is not supported and closed the case :frowning:

Version 4 Siler Efex or Viveza does not work on tiffs or psd.

Also Version 4 wipes out version 3.

This is the issues people are having

1 Like

I also noticed that when Silver Efex and Viveza are used as plugins in ACDSee Ultimate that they open and you can make changes. However, when the plugins are closed the changes are not applied, it appears like Capture One. However I do also understand that ACDSee is not supported with the Nik Collection by DXO. Viveza didn’t work with ACDSee previously, so no loss there. However Silver Efex did work previously. Luckily I have recently switched to Lightroom/Photoshop (I know the opposite direction of where people appear to be going) so I can still use Silver Efex. Just thought I would add this comment.

This may be the case but it doesn’t explain why the previous version of NIK Collection worked seamlessly with C1P and yes of course I uninstalled NIK4 immediately and reverted to the old NIK Collection which as expected works just fine within C1P

So in a way even though it may not have been “officially” supported it always worked with C1P before and still does (previous versions that is) so I can only view this as a step backwards. It’s all well and good having a sleek interface and some nice to haves, but what’s the point if they can’t get the basic functionality working like it use to. Huge disappointment is an understatement, not happy :frowning:

Indeed. There are a few things in Nik4 that don’t work out too well and I’m sure that DxO is busily working on the respective fixes. Maybe the release of Nik4 was a bit premature too… Meanwhile, we’ll have to wait for updates. I’d not hold my breath though.

1 Like