Nik will not install on Macbook pro

Title is self-explanatory. I am no computer geek. I have downloaded, run the install program, there is a folder called Nik but it is empty. Uninstalled and tried again in case download is corrupted. Running latest Apple software and PL5. What is my issue please?

You really need to give us more information.

Did the installation complete successfully and say that it had been installed?

You say there is a folder called Nik, but where is that folder found? The expected folder name would be Nik Collection, found under the Applications folder.

Can’t you tell us the exact sequence of events, from when you opened the disk image, that led you to believe it has not been installed?

Yes, sorry. Downloaded installation file, sucessfully so far as I know. Double clicked to install, it went through the installation process, including clicking the “Finish” button. But Nik is not showing up in PL, nor in Launchpad. There is a folder in Applications called Nik Collection, but it is empty.

A standard installation should proceed like shown in the screenshots below, make sure to check the required boxes or the installation will not proceed:

Select language:

Accept to overwrite a previous installation:

Accept license and data protection agreement:

Verify and accept target folder:

Check (or add) applications that should get the plig-ins:

Confirm to install in the macOS popup window:
(no screenshot)

Installation starts, progress bar moves slowly at first, jumps a few times…

…until the installation process can be closed (push the yellow button)

Verify the installation in the Finder: The NIK Collection folder should contain the items shown in the rightmost column of the screenshot (everything els can be different on your Mac)

1 Like

Yes, everything proceeds exactly as described (though in English), except that the Nik Collection folder is empty when the process is complete.

Odd… Have you tried to re-install?

yes - uninstalled and re-downloaded and reinstalled, same issue. If this is not a known problem I am going to try to free up some disk space (I am down to 4G) and try again this evening.

though it claims the software only needs 2G, and if there is not enough space I am not sure why a warning would not come up

Hi @platypus
in connection with this post I have another question.
If you uninstall a software under Windows there are usually remains things in the filesystem (user directory) as well as in the registry (sytemhive and user hive), which you have to remove manually.
How do you do a clean uninstall under MacOS?

Is there a log file in the temp directory?

Mac apps might look like a single executable file with the app icon but, in fact, they are a specially marked folder (or bundle) that contains all sorts of components and resources that the app needs. If I show the package contents of, this is what I see in Finder…

There are also a couple of standard locations under the Library folder like Application Support and Preferences where runtime stuff gets stored.

As you know, in theory, all you need to do to “uninstall” a Mac app is to delete the App bundle but, in fact, you should also look in the Library folder for anything that mentions the app’s name or publisher.

1 Like

4GB is nowhere near enough for the computer to function properly. Not only will it prevent installations, it will also prevent the OS from swapping out memory to disk while apps are running.

It is highly recommended that you never leave less than 50% if your disk is only small. What size disk do you have?

1 Like

…with quite a lot of effort searching…you’ll be amazed to find hundreds of leftovers…also in invisible folders…

I use “FindAnyFile” or “EasyFind” and look for file names containing the words listed below - and carefully looking at search results (lots of false positives) before trashing anything.

  • dfine
  • dxo
  • efex
  • install
  • plugin
  • nik
  • selective
  • sharpener
  • viveza

If you’re friends with the CLI, the “find” command should do too…

Note: Carbon Copy Cloner has a tool that identifies differences between backups/snapshots. This could help to find all the crumbs that Hansel and Gretel have spread all over the forest…


Thanks a lot.
Is there anything like the registry on Mac?
I’m still a apprentice in Mac World :grinning:

No, it’s not necessary

Some applications deposit binary “bill of materials” and other files in a hidden folder.
Venture into that realm at your own risk.

The counterpart in the broadest sense is the “Library”. Both the “User” library (in which only the settings of the respective user are stored) and the one in the root directory under “Macintosh HD”:

The “User” library is not visible by default. You can reach it in the Finder via the menu bar “Go to” (or “Go to Folder”, I don’t know the name in English) > “Library”.

I think the library is more the counterpart of C:\Users<username>
The registry is a bit more in windows

that’s only a snipet :smiley:

THE library does not exist on macOS. There are many “Library” folders:

  1. /Library ← used for items that act system-wide (preferences, plug-ins, caches etc.)
  2. /System/Library ← macOS’ own Library, do not touch
  3. /Users/FritzTheCat/Library ← used for items that act user-wide only
  4. Other “Library” folders

DxO drops items in the /Library and /Users/FritzTheCat/Library folders. Not all of DxO’s apps drop items in the same places, which means that, for a clean wipe of DxO apps, we need to remove things in many places. Folders 1) and 3) from the list above are good places to begin with.

Hi. I have culled some photos and now the download works. Thanks for your help and sorry for troubling you - clearly my fault. I have a 1TB SD drive so plenty of potential capacity, just need to be more ruthless with culling and off-line storage.