Nik Efex freezing Photoshop 22.2, even using Rosetta workaround

Just got a M1 MBA, the base spec of 8GB/256GB SSD.

It won’t be my main processing platform, but I was hoping that it would usable when travelling for some processing at least.

I struggled initially to get Nik Efex (the free version) installed but a Google search led me to threads here and elsewhere - indicating the workaround was to open PS using Rosetta. Did that and, sure enough, the Nik collection then showed up under filters.

My usual workflow involves a few tweaks in LR, then importing into PS using the right click option. Doing this however I found seemed to open PS by-passing the ‘open using Rosetta option’ as the plug-ins were no longer visible in PS…

The obvious workaround was (I thought) to have PS already open when using the right-click - Edit in PS command, as leaving it to LR to open PS clearly wasn’t working.

That seemed to do the trick (initially) as Nik Collection was now visible and all seemed good until after I had applied a couple of filters (in Color Efex) and then hit the OK button in Color Efex… the Nik window disappears and I am left with a progress bar that initially moves along applying the filter but then ALWAYS freezes - usually at the Preparing Preset Image point - and locks up PS too, leaving me no other option than to Force Quit.

I’ve tried also having LR open via Rosetta, in case the issue was that the two Adobe applications both needed to be operating via Rosetta. Made no difference.

I’ve also just tried going back to Photoshop 22.2, which seems to be the most recent pre-ARM version, still freezes at the same point…

Has anyone with the base spec M1 MBA managed to get the Nik collection working properly? I’d welcome any advice or suggestions!


I have the MacBook with the M1 chip and the new Nik 5 is crashing Photoshop 2022.