Nik Collection won't activate upon re-install

Nik began crashing Photoshop over the weekend. Mid-Day Monday, began trying to figure out the problem. Ultimately came down to uninstall, reinstall. Problem now is I’m getting an “registration error” and the install won’t complete. Love the product, it’s a vital part of my daily workflow, but very underwhelmed with support. It’s been 25 hours since I submitted the “diagnostics” file they requested, and still no reply, only a defensive exchange with a FB messenger response tech.
Absolutely no other issues within my computer on any level, yet can’t get this reinstall to complete. Anyone have any ideas??
Oh yeah, I’ve rebooted several times, uninstalled the program at least 4 times and started from scratch.
I’m pretty sure at this point I’ve been black-balled by the support “team”, which means ultimately I’ll end up with another software package.

Windows 10? Did you install a system update over the weekend? (That’s what wrecked my DxO software.) If so, do this:

  • Launch Windows PowerShell with Admin privileges. (right-click on the Windows Start icon)
  • Run sfc /scannow
  • If errors are found and can’t all be fixed, use dism:
  • Run sfc /scannow again.
  • It might be wise to reboot now.
  • Reinstall your DxO software. (You might not have to uninstall it first.)
  • You might want to reinstall Photoshop, too.
  • Run your software. If there are still any problems, check the Event Viewer System and Application logs.

Best wishes.

Thanks for the reply. Just spent over an hour with a DxO tech logged in remotely. They even got a developer involved, but eventually gave up and offered a refund, which I don’t want, I love the Nik Collection. I may have some underlying issues as you mention with maybe an update that I’m not aware of over the weekend. I’m leaving on a cruise in the morning and leaving my machines in the good hands of my computer guru for a week. Hopefully he can get me back up and running.
It’s odd though, no other app is having any issues. I purchased another batch of presets and profiles last night, downloaded and installed with no issues, and everything else seems to be fine.

And yes it is very annoying that one would have to wait more then a day to before approving the post. Not ideal if one needs urgent help :rage:

1 Like

This is very common issue. I’ve been having it for few years before nik was bought by dxo. I’ve reported it a year ago. Still no solution. Check out this video -

It does work, however it requires manually to enter the preset name each time using the filter. Otherwise you are lost which presets you’ve been using. Far from ideal

For such cases you have a support team - where you can address all your problems.

Svetlana G.

That is correct. But so far my experience (apparently not just mine) is that support fails to respond in the first 24 hours. And when it does, it’s only 50% solving rate (mine experience). Again not ideal!

1 Like

Just a follow up… after leaving my system with my computer guru while out of the office for the past week, He managed to get Nik Collection to reinstall, and all seems to be ok from two test runs this morning. What did he do??? I have no clue, lol. Got in late last night and my desktop was waiting on me in the office, and I haven’t gotten to talk to him this morning.
However, the “REAL ISSUE” here, and concern for DxO is what seems to be common, customer support. Not sure what “model” DxO is following, but by the reviews I’ve read, and now my personal experience, it’s not ideal.If you are only serving customers in your time zone, and they only have issues 9-5, you’re probably covered, because it’s obvious you’re not going out of your way to be available any other time, which sucks for your international customers. Just sayin’!!

So I purchased the Nik Collection (I am a Photolab 2 user) on the special that ran last week. I am unable to download the software. If you go to, you are prompted to type in your email address with the promise that a link will be sent to you. This link never comes. Yes, I checked my spam, to remove that variable. I have done this since Friday.

Any suggestions? There is no email to contact, so I am hoping that someone from DXO actually reads the forums.

Hello @mbhweiss,

Please, address your problem exactly to the support team - - they can handle such cases but not the forum guys.

Svetlana G.