Nik Collection disconnects from PL7, still accessible in Affinity

Nach einer Testversion von PR3 habe ich PL7 Elite gekauft und bin noch in der Lernphase. Mein vorher erneuertes NC6 wurde erst in PL7 zugreifbar, nachdem ich die Vorgängerversion 4 de-installiert (via Windows Settings/Apps) und Version 6 neu installiert hatte.
Nun hat sich der Nik Collection Button mehrmals verabschiedet, sprich die Menu Taste meldet ‘Nik Collection is not installed on your computer’, obwohl die Programme einzeln aufrufbar und in Affinity 2 zugreifbar sind.

Wie kann ich die Verknüpfung NC6 - PL7 wieder erstellen, ohne stets über de- und re-installation gehen zu müssen?

Meine Konfiguration: hp 17" Laptop, i7, 16 GB, Intel iRISX, Win10Pro (22H2)

Besten Dank für Tipps

After a free trial of PR3, I bought PL7 Elite and am still in the learning phase. My previously renewed NC6 only became accessible in PL7 after I had uninstalled the previous version 4 (via Windows Settings/Apps) and reinstalled version 6.
Now the Nik Collection button greyed-out several times, i.e. the menu button reports ‘Nik Collection is not installed on your computer’, although the programs can be called up individually and are accessible in Affinity 2.

How can I create the NC6 - PL7 link again without always having to uninstall and reinstall?

My configuration: hp 17" laptop, i7, 16 GB, Intel iRIS X, Win10Pro (22H2)

Many thanks for any tipps

Hi Christoph – and welcome to the user forum,

can you check if …


Hi Wolfgang
as said, I am still exploring the DxO environment, coming from LR6 and am pleased to find an active user forum :slight_smile:

The plugin selector is/was always visible, but randomly prefers to give this error msg
Screenshot 2023-11-04 121907

I tried to use the NikCleanup script, but Win10 security settings won’t let me run this PowerShell script, and I am too lazy to dig deeper into that problem.

Regards, Christoph

Well, I’ve never used (needed to use) this special tool to cleanup, so I can’t help you in that regard. I’m a longtime windows user with some experience & understanding, but no IT specialist.

And yes – I would have deinstalled and reinstalled PL and Nik … but what you describe as temporary blockade makes me think about access problems. No idea if that’s the right ‘track’.

Just try again with a thorough reinstall. … And maybe then somebody else will help you further.

I have this same issue. Just upgraded licences to PL7 and NC6, installed NC and initially worked as expected but today when I open PL7, the NC button is greyed out and pop up says NC not installed (but it is!). Any ideas on making it work without having to re-install both programmes?


My problem of a broken link between PL7 and NC6 is solved for the moment.
I have AVG internet security installed on my Win10 machine, including AVG Tune Up, a performance optimizer that cleans out garbage files, broken shortcuts, tracking cookies …
Upon a hint from DxO support to check for automatic cleaner SW, I rescheduled Tune Up from weekly to monthly and Bing! the link PL7 - NC6 remained stable.
Now, I am pondering how to fine tune the cleaning SW to spare all DxO stuff from its efforts, or alternatively, how to create a backup copy of the affected files/registry entries that I can recover quickly from a disconnection. No luck so far, there are hundreds of DxO files and dozens of reg entries.

Best, Christoph

Thanks. May have been a result of me running the “My Dell” clean up routine a few days ago.

A bit rubbish if the link between NC and PL is something that a number of different PC clean up apps consider to be deletable though. Surely DxO should be building that link in a more resilient way?