NIK Collection 5 Version 5.0.5 x64 (5.3.0) update

I want to alert DXO PL/NIK Collection users of a download issue I just experienced on downloading NIK Collection 5 version 5.0.5 (x64 (5.3.0) update for windows on both my laptop and desktop.

After the installation of the update for NIK, when you click on NIK Collection in DXO PL6.1.1. nothing happens. The NIK tab is greyed out.

I solved the problem by uninstalling NIK Collection 5 and then reinstalling it from the NIK Collection update in my Downloads Folder on C drive. Once it was reinstalled “fresh”, I was able to access it from DXO PL6.1.1. (The NIK Collection tab was highlighted. )

One thing that might be causing it to occur is that the update process has a screen near the end where it asks you to restart (reboot?) your computer before you get to the Finish screen. This is the first time I have ever been asked to do something like this.

I have not reported this to DXO yet, but will do so if needed.

The same thing happened to me. Same system as yours. Would really like the answer to your question as well. I am going to uninstall and reinstall Nik as you did. Hope it works for me using PL 5.

I have seen a similar issue, but during a clean install of Nik Collection 5 on a new PC. The install appears to complete, but it does not create or populate the “C:\Program Files\DxO\Nik Collection” folder, nor does it create and populate Adobe plugins folder (“C:\Program Files\Common Files\Adobe\Plug-Ins\CC\DxO”). It seems a bug in the installer. My fix was to install Nik Collection 4 then install v5 over the top (similar approach to your discsussion). I could see the successful v5 install completely remove the v4 files and the Nik Collection folder and then SUCCESSFULLY recreate and populate it and the CC plugins folder

Bottom line is that you need an installer OTHER than the current x64 5.3.0 in order to install the product. I have now raised a support case with DxO for this.


Thank you Peter and SailAway. I just wrote DXO Support and reported this issues too.

My operating system is windows 10 Pro on both my desktop nd laptop.


I’ve had the same issue. Also reported to DXO Support.



I also have the problem when I down loaded NIK Collection 5, version 5.05. The NIK Collection disappeared but I cannot uninstall it because it is not on the computer (checked the application list but only DXO Raw and Photolab are listed). In addition Photolab confirms NIK Effects is not on my computer (Windows 10).
Problem is when I try to reinstall NIK Collection v5, I get a notification that it is already installed on my PC and will not let me proceed. Something must reside on my PC from the original install attempt. I have searched through all the proramme files but cannot find anything. I’m in an impass and would appreciate advice.

1 Like

The same thing just happened to me on my Windows 10 system.

After I created the C:\Program Files\DxO\Nik Collection\ directory myself,
the installation worked correctly.

The installer for DxO PhotoLab 5.6.1 is also flakey.
It will not install to the C:\Program Files\DxO\DxO PhotoLab 5\ directory until
you delete all the files in the directory left over from a previous uninstall.

So far the response fro DxO support has bee the usual mindless form response,
telling me to re-download the installer, uninstall and re-install.

1 Like

Did you ever resolve the problem as I am experiencing much the same. Nothing visible to open the software in file manager, but visible in add and remove programs and in CCleaner. However the program is not able to be removed by either due to a glitch in the removal software. And as you found trying to reinstall is met with a message telling you the program already exists.

Try THIS to uninstall the program. Be advised this will completely remove everything associated with Nik 5. You should backup your user presets and anything else that you wish to keep before uninstalling. After uninstalling redownload Nik 5 and reinstall then replace the files you backed up.

My downloading problem (on Win 10 Pro) seems to have disappeared. I am now using DXO PL 6.3.1 Elite.

NIK Collection is now version 5.5.0. I just found this out when I accessed Color Efex Pro from DXO-PL 6.3.1 Elite… When NIK informed me of a new version as I was accessing it, I did say Yes and downloaded it.

After downloading NIK 5.5.0, I closed DXO Pl and any other open programs. I then went to my Downloads file folder on C : and clicked in NIK Collection 5. It installed it.

Then I opened DXO PL 6.3.1 and accessed Color Efex Pro from Nik Collection 5.5.0. ,

I hope this helps.

no problem here with the latest update

Continuando a discussão de NIK Collection 5 Version 5.0.5 x64 (5.3.0) update:

Hi Marc
I have now resolved the problem.
I woke at 3am and tried a few programs to remove the rogue copy… Without a solution.
However I found a ms forum post for a similar problem and they suggested their troubleshooting tool.
This removed the rogue software easily and the software was then reinstalled.

Glad you got it sorted!