Nik Collection 5 and Lightroom - not working whatsoever

When I attempt to edit a file in any of the Nik Collection (as plugins for Lightroom) I have problems which ultimately result in me having to close LR and lose any changes made in Nik.
(I am using a Mac with Monterey v12.5 - it was 12.4 when the problem first occurred. System specs are: 2017 27" 4.2GHz Quadcore Intel i7; 64GB RAM)

The issue started when I upgraded from Nik 4 to Nik 5 some weeks back. Initially when attempting to edit the file in any Nik 5 plugin (Silver Efex, ColorEfex etc), nothing happened except that I got an extra .tif image in my LR library. LR would then become unresponsive and I had to "force close it " i.e. the equivalent of the Windows Ctrl-Alt-Del. I uninstalled Nik, and re-installed it. This made no difference, so I stopped using Nik at all.

Recently, Nik brought out a new version (5.02 I think [?]). I installed this and although it still doesn’t work, the errors are different. Now I can send the image to the plugin and edit it there. On return to LR, the "Nik-edited’ image shows BUT there is no histogram and the keywords flash on and off like a set of blinking Christmas lights. In addition, LR becomes sluggish and mist functions on the dit bar are greyed out…

I have tried uninstalling, Nik and re-installing it but this has made no difference. LR is working absolutely fine for everything else , Nik excepted, including other plugins such as Topaz.

Help will be greatly appreciated!

Hello. If you’re still having this problem, you might try upgrading to Nik version 5.1. The release notes have a fix listed, described as a correction for “Long loading of the Nik Collection effect while saving changes from Nik Collection to Lightroom Classic.”

I was having a similar problem with versions 5.0.1 and 5.0.2. After I edited a TIFF file in Color Efex Pro 5, and returned to Lightroom, Lightroom would be unresponsive for several minutes, but would eventually finish updating the image. If I tried to process several images in Color Efex as a batch, then I’d have to force close Lightroom. Lightroom would get stuck “writing metadata” or “reading metadata” – something that should happen so quickly you don’t notice it.

The 5.1 version has improved things for me, though it’s still slower than it was with Color Efex Pro 4.

The other thing I saw while trying to find a way around the performance problem was that if I initially created the TIFF file with one of the Nik apps that hasn’t been updated to the new UI (Dfine or the Sharpener Pro apps)… then worked on the same images in Color Efex Pro 5, Lightroom handled them normally. Hopefully DxO is still refining how changes get passed to Lightroom and this will improve over time.

(FYI, I am also on a Mac, an M1 mini, and at Monterey 12.5.)

Good Luck!

1 Like

Thanks, Daleducatte. I have upgraded to Nik 5.1 and am still having similar issues. I am in contact with DXO now, and they have sent me a diagnostic tool to run immediately after I attempt to edit a file and I have this problem - hopefully we’ll get to the bottom of this. I’ll keep you posted.

1 Like

I’m on my 4th try with the diagnostic tool as i’ve been having the same problem since upgrading to Nik 5. Tried latest version of Nik released yesterday and absolutely no different. As i sit here now its been 20 minutes and still cant open a file edited in Silverefex in LR as its still “gathering” the necessary info. Nik for me and my workflow has become effectively unusable. Been back in touch with DXO support one last time - waiting for a reply

I’m waiting now - the diagnostic tool upload and the video I took of the problems wasted enough time. This is such a pity as Nik 4 was better than great and a large part of my workflow for a plenty of old images. If this doesn’t work, I’ll probably have to give up on Nik, at least for a few months, by which stage (hopefully) their software will have caught up…

UPDATE: No change. DXO informs me that the files I am sending to NIK are too big. They are no different to the ones that Nik 4 worked perfectly with - in many cases old jpg files from the 1980s!? Their solution is that I must wait (several minutes) and rename the file on its return from the plugin (Nik). This is really frustrating (sad) as Nik were my favourite plugins for LR

If your file is a JPEG or TIFF, it should be processable in any Nik app straight from the drive.

Can you process and save your image in standalone mode? Open e.g. Viveza, open the file, customise your image and save changes?

Is there a limitation in file size…I’ve never heard about, also because a lot of people here are working with monster cameras :stuck_out_tongue_winking_eye:


I can - but that’s not the point.

I have always used Nik as a plugin for Lightroom and it worked perfectly up to the very last version of Nik 4. Using it as a standalone when all my images are in LR is incredibly slow and not worth the time. Yesterday, I thought I’d give it one more go. I completely removed LR, PS and Nik from my Mac, (including manually removing all traces of Nik as a preset from both of these programs). Rebooted my machine, checked for traces of Nik, rebooted it again and re-installed the three programs.

I then tried again (with a smallish image file i.e. <2Mb) and still had the same problem(s)… LR is working fine with everything else including Topaz plugins with large files (>50Mb).

There might be!? but with Nik 4 I was using the same type/size of files and had zero issues. I can’t get Nik 5 to work as a plugin even with relatively small files (~ 2Mb).

The point is, that we now know that the issue is with handing over files between Lr and Nik. This means that

  • you can still use the apps
  • DxO needs to fix the plugins

Working with standalone apps feels more annoying than using plugins, but at least, it enables you to get the results you like. If that is not enough, you could fall back to Nik4 and insist that DxO support help you.

I’m new to Nik and encountered the same LR problem. My workaround was 1st send to PS, the Nik plugins are on the screen when the photo opens, select your Nik plugin. When saved it returns to PS and LR with the changes. For sure not perfect but it works.