Nik Collection 4 with Capture One Pro

I’ve been using the Nik Collection 3 (especially Silver Efex) as a plug-in in C1 Pro for a long time without any problems.

After upgrading to the Nik Collection 4 and reintegrating it into Capture One Pro, a problem arose for me. With Silver Efex Pro 3, HDR Efex Pro 2 and Viveza 3, I was able to open the respective application via C1 and then edit the image. After the image has been saved (e.g. in Silver Efex Pro 3), however, the information from the conversion in SW is no longer transferred to the Tif photo in C1, i.e. the generated Tif photo remains in color. The same thing happens with the other two programs mentioned.

It would be very sad, if this workflow doesn’t work work like this any more. Has anyone had similar experiences?

Yeah, saw the same thing. Watching carefully, you can see that Silver Efex does not complete the Processing Image phase - i.e. the progress bar does not complete and does not go on to the save step. This looks like a bug that would be pretty easy to fix but DxO don’t agree and simply stated that Capture One is not supported.
I am having to generate the TIF from C1, then locate the new TIF in the file system and using “Open With” from Windows Explorer and selecting Silver Efex Pro. Now, the TIF does get saved and I can go back into C1 and regenerate previews to get the black and white picture to show up.
I will use it for a while longer before deciding whether to pay for it as-is or go back to the free version.

Thanks for the information concerning C1. I won’t upgrade if this isn’t able to be resolved. DXO seem to be targeting PS/LR and aren’t bothered about NIK for other applications. Probably a good business call but it risks generating negative customer reactions from existing customers who are impacted by this PS/LR focus, toward the whole DXO suite of products.

Fully agree. Nik 3 worked excellent together with C1. Should not be a big deal for them to adjust the problem for Nik 4 even when they officially do not support this plugin. The combination C1 - Nik Collection is just perfect for me, particularly with Silver Efex. However, an efficient and smooth workflow appears to me essential. Will probably have to think over this constellation in the future based on that C1 will stay as my main working tool.

C1 just calls NIK as an external editor and passes the TIF to NIK. I wonder why NIK fails, it should be simply operating as a standalone app?

Ian, I am not technically experienced but I think you are right. The NIK editing process itself is not the problem I see. As said, when instructing C1 to edit the picture in NIK, C1 creates a TIF and passes it on to NIK (in my case mainly Silver Efex). With Silver Efex I then can create my BW version, which works absolutely correct. The problem comes up when trying to give the BW version back to C1, which worked perfectly under NIK 3, but not under NIK 4 (i.e. the edits from NIK 4 do not end up in C1).

One of the possibilities is that the file is there but you just can’t view it. Let me explain.

I’m on Windows and use PhotoLab to launch the Nik Collection. I have noticed in the current and previous versions of the Nik Collection that occasionally, after I finish editing an image in the Nik Collection, the finished image is not displayed in PhotoLab.

Using Windows File Explorer I researched and found that when this happens the returning file is actually there but has a .tmp extension added to it. The format is Filename.tiff.tmp or Filename.jpg.tmp. I found that after manually renaming the file by removing the .tmp extension, it then becomes visible in PhotoLab…

Clearly this is a bug when Nik processes and returns the file. Not sure if you are having the same issue, but you might want to check in the folder you were expecting the image to be in using FIle Explorer in WIndows or Finder on a Mac. In my experience the problem seem to come and go. I had this problem after using Viveza just yesterday and today it works fine.


1 Like

Hi Mark,
the experience you described occured actually to me a couple of times with Nik Collection 3. I checked it now also with Nik Collection 4, but couldn’t see this happening with my installation. There is just no file coming back to C1.

As I need to work with the software smoothly I have reinstalled Nik Collection 3 again, which works perfectly together with C1.

I hope there will come the day when DXO will look at this issue, even when this is not an offcially support plug-in. Have a good time!

I’ve experienced this problem a couple of times and simply restarting PL4 solved the problem for me.

1 Like

I’ve the same issue, and this is the answer by DXO:
" Greetings,

We unfortunately do not support the use of our software with Capture One, our apologies.


Riley - DxO Labs Support Team 2"
No mention on site about this limitation!!! Absolutely , no good !

Just jumping in here: yes I too experience this issue and it appears to be a direct slap in the face of C1. My workaround involves opening said tiffin PS, then Nik, then merge layers, then back to C1.
I’m offended I have to walk thru all those additional steps and my carpal tunnel hates it. And that makes me unhappy with the current Dx0 decision.
The position taken by Dx0 appears incomprehensible to me.
Do I own Dx0Photolab, LRC + PS (and others)? You betcha! However, in my workflow, their use is relegated to plugin status for C1. Because that’s what works for me.
Making me work harder does not make me happier.