Nik Collection 4 "Installed" on PhotoShop CS6, but

…It sorta did and didn’t. It shows up under PhotoShop’s “Filters” but running any module gives you an error. That it didn’t work wasn’t a big surprise (it’s not CC2020/21), so I uninstalled it. When I was getting ready to reinstall Nik Collection 3 I went to my DXO account and found out that they wiped out most of my previous software information, and ALL of the purchase history except the “4” purchase. So no “3” Activation code.

I asked for a refund, but to get it they tell me I have to submit to a TeamView session conducted during DXO’s office hours – not mine. Non-starter. And why would I let anyone from DXO take control of my computer?

I’m going to keep pushing them for my “4” refund and also to get my account information restored…But I suspect they’ll be kicking and screaming all the way.

I was liking PhotoLab4 a lot, but the non-existent and/or tone-deaf “support” staff really has me reconsidering sucking it up and going with PhotoShop’s subscription version. I wouldn’t be surprised if PhotoShop makes a jump into a more more AI-centered application.

Meanwhile, with all this admin trouble happening at DXO…Anyone heard if they’ve been a victim of ransomware?

Update, 13 JUN 21: I installed the subscription version of PhotoShop, poked around, and decided it wasn’t worth it. So I’m sticking with CS6 with Nik Collection 3. If I need enhancements, I’ll look for plugins from Topaz or someone else.

I’m surprised you didn’t run into the issues you’re having during the free trial…


My bad…I trusted them enough to buy it, not suspecting that they would need to take control of my computer in order for me to get a refund.

Never again.

And since they stopped sales of Nik Collection 3, which worked with a number of other platforms, they lost the ability to use Nik Collection as a gateway to PhotoLab and other software. Their marketing people are stunning that way. Kinda like the situation with Fujifilm X-Trans shooters who would be quite happy with 95% functionality in PhotoLab4, but DXO has decided that those photographers would be even happier with 0% functionality.


I’m using Nik Collection 4 fine in Photoshop CS6. Windows 10 Pro 21H1.

As a plugin you get to from “Filter”? It absolutely didn’t work for me, though it probably worked as a standalone. Over several communications with DXO it was confirmed again and again that Nik Collection 4 was not supposed to work with PhotoShop CS6. I elected to buy another plugin from Topaz with the money and keep Nik Collection 3.

HI, I’d just thought I’d update:
Windows 11, PS CS6, Nik 4.

Works as a filter, but I had to make sure that I didn’t use save as a separate layer, but as the current image, layer, whatever, in the Nik Preferences.

Nik 4 never worked with my old PS.
– And there is nothing so revolutionary, what I couldn’t do with 3.3.

Update to update: Color Efex Pro 4 works, Silver Efex gets error message (I never use it so I assumed it worked, mea culpa). They all work in the equally old Lightroom 6, at least as far as I’ve tested (I detest Lightroom). I think I’ll now bow out of discussion with remnants of my tattered dignity intact. :slight_smile: