Nik Collection 4 and PhotoLab 5: Output Sharpener, Dfine and Pre Sharpener crash

Hello all,

I have a massive problem with 3 particular Nik Collection modules and have already created a support ticket yesterday. Just curious if anyone knows of this problem, or even has it themselves. Thanks in advance for reading.

I am working on a new MacBook Pro 16" M1 Max 2021. Installed is macOS Monterey 12.1. The system was set up just a few days ago.
As part of the setup, I installed all my DxO products:

  1. PhotoLab Elite 5.1.0, Build 47.
  2. FilmPack 6 Elite, version 6.1.0, Build 199, 64bit
  3. ViewPoint 3, version 3.2.0, build 254, 64bit
  4. Nik Collection 4, version (v4.3.0)

I do not have any Adobe software installed and I have been working with PhotoLab and the Nik Collection for years (on a MacBook Pro 2015).

On this new MacBook Pro I now have problems with Dfine, Pre Sharpener and Output Sharpener. I hardly ever use Dfine and the Pre Sharpener, but the Output Sharpener is always the last step of my workflow, since PhotoLab unfortunately doesn’t include any possibility of customized output sharpening. So Output Sharpener is extremely important for me.

In PhotoLab, when I send an edited RAW, TIF, or even a JPG to one of the three modules mentioned above using the “Nik Collection plug-in selector button”, the image file is converted and created according to the settings, but none of the 3 modules open, only flashing for a tiny fraction of a second and crashing immediately. Exactly the same happens in stand-alone mode.
All other modules (Analog Efex, Color Efex, Silver Efex, Viveza) work normally at first glance. HDR Efex I have only tested with a single image so far.

What I have tried with no success:

  1. Uninstalled the Nik Collection using the uninstaller in the installation package and deleted any leftovers using Finder search, then reinstalled.
  2. Installed the Nik Collection over the existing installation.
  3. Start Output Sharpener with the option “Open with Rosetta” activated and set the rights for “everyone” to “Read & Write”.
  4. Worked through the following note from the DxO Help Center: “The plug-ins in the Nik Collection utilize Arial fonts and in some situations, a duplicate Arial font may have been created which may cause unexpected errors. If you are experiencing otherwise inexplicable crashes with the plug-ins, removing all duplicate copies of the Arial fonts often resolves the crashes.” However, there are no duplicates.

Any ideas?


Of the apps you listed, I only use Nik Collection (version 4.3), and have the same problem with Dfine and the two Sharpener apps. I use them with Lightroom Classic, but as you noted Dfine crashes even if launched on its own when using File/Open from the toolbar. All the other apps work fine; I’ve used them to process files and didn’t have any issues.

I’m using a Mac mini M1, and the problem started after upgrading to Monterey 12.1. Prior to that, they worked as long as “Open using Rosetta” was set for the three apps.

I have a second computer – a MacBook Air 2017 (so not an M1 processor) also updated to Monterey 12.1 – and the three apps fail the same way on that machine too … so this isn’t an M1-specific problem, but I guess must be some incompatibility with Monterey 12.1.

I tried the first three things you did, and also tried giving the apps Full Disk Access in Security & Privacy system settings … didn’t work.

So I don’t have a solution, just wanted to let you know someone else has the same problem. Thanks for reporting to DxO; I hadn’t gotten around to doing that yet. Let us know if you hear anything.


1 Like

Thanks for your reply, Dale. Yes, if I find a solution with support, I will report it here.

Yes indeed. Those aren’t modules I use much so I hadn’t noticed, but I did test Dfine earlier this year, before Monterey. M1 Mac Mini, 12.1, Nik 4.3. All three crash when opening jpg and tif standalone or from Photo Mechanic. (I haven’t looked into fonts.)

I also have an Intel MBP but it’s not yet upgraded to Monterey. No crash with Dfine. I will probably upgrade soon so at least can test with Monterey/non-M1.


1 Like

Thanks for your feedback too!

have the same exact issue and tried the same steps with no resolution.
All the other apps work fine on my M1 iMac. Only Define and Sharpeners crash when attempting to load an image.

1 Like

Thanks for your reply!

Same issue here.
IMac 2021 M1, Monterey 21.1, Photolab 5.1.1 Elite, Nik

1 Like

Thanks for letting us know.

A few days ago, support told me that they will pass my log files to the developers and get back to me as soon as there is news.
I will keep you updated.

Thanks for doing that. I hope they can fix this issue. I don’t use those apps often but would like to be able to use them!

1 Like

The problem seems to be affecting all macs running Monterey (not only M1). I am using PhotoLab 5 and both Output Sharpener and Raw Presharpening are crashing (irrespective of whether run as standalone apps or plugins) – reported bug to DxO…


Hey Klick, has DxO provided any status updates?

No, not yet. I guess because of holidays. As soon as I know something, I will definitely post it here.

I have the same problem but can work around it, at least with Output Sharpener, by opening the file as a smart object in Photoshop and I am then able to open Output Sharpener and it works as expected. I have not tried define or pre sharpen

I have exactly the same issue with my iMac 24". I normally open one of the three apps from Capture One and they crash, but the same happens when I use them as stand alone app.

Same here. Very frustrating. I use Sharpener Pro 3 in Lightroom Classic as part of my film negative workflow…and now I’m stopped dead in my tracks. Arrrggggg!

@scillysurfer: Thanks Mark, at least for people with Photoshop there is a workaround.

Thank you all for your feedback.

I just did a test with Affinity Photo and all THREE plug-ins do work within Affinity. So even for people without Photoshop you have another method to access these plug-ins.

I have received message from support team:

Our development is working on the solution of the problem. It results from updates to the operating system and related changes.
Unfortunately, at the moment I can’t tell you when we will be able to offer you a solution, we will get back to you as soon as there is news.

Interesting that there are no problems with Photoshop and Affinity.