NIK Collection 2 won't install - Application Error Message

I bought DXO Photolab 2 and NIK Collection 2 (“NIKC2”) over the weekend (on 11/30/19) and have been struggling to install NIKC2. I’ve since upgraded to Photolab 3 Elite in case it would help; no change. I’ve tried right-clicking using “Open” and “Run As Admin.” with no success. I keep getting an application error that it could not start correctly (0xc000007b) with every single trial. I even disabled my virus software to see if that was blocking it; no difference. I’ve asked “customer support” and we are on day 3 now with no help from him/them. My PC meets and exceeds the requirements to run NIKC2. If there is someone out there that can help I will be forever grateful. Olga:worried::worried:

I’d try the following steps:

  1. Activate your license on
  2. Log in to your shop account and
  3. Download the software again

Then try to reinstall.

Hi platypus, I did and the same error message appeared.

However, I finally got an response from Support and they sent me a diagnostic file that collects info to see if they can figure out what is going on. In the meantime. I just ran it a couple of minutes ago and sent it to them. We’ll see what happens next. Hopefully, they find a solution. Thanks for trying. Olga

NIK support still has not figured out what is wrong. It must be a real problem if they still have not figured out what is wrong. :worried:

I think the only way is to delete the program and clear folders from your pc, re download and install again. Might had just been a bug during install but still in those folders preventing it from running.

Today I spent about an hour with one of the engineers/IT in France. We had to stop because it was their end of the work day. He said that he will have to analyze the data he downloaded. He was doing things remotely on my PC. He thinks it has something to do with my PC; I have a Dell XPS. We’ll be going back on this on Friday or next week. And BTW, I’ve tried all the different suggestions of what to do. Nada!

I have the same problem.19 days without any solution from DXO!!?? Since 5 days they don"t answer anymore

Last week, they put my ticket on hold due to the holidays AND because it is not a high priority because “other people are not having this issue.” I am wonder if it is perhaps a specific computer problem. I just discovered that I was able to install it on my laptop. I own Dell XPS desk- and lap-tops. The problem is on my desk-top. What type of computer do you have? It would be very interesting if you also use a Dell XPS!