Nik 6 on Affinity Photo 2.1 is broken

Nik v6 worked great on Affinity Photo 2.0 BUT Affinity just released an update to 2.1.
After updating Nik6 still launches but the Cancel/Brush/Accept buttons don;t show up.
I tried rverting to Nik 5 and all worked perfectly, reinstalled Nik 6 and its broke.
So it seems to be an integration issue betwen Affinity Photo 2.1 and Nik 6.
Having paid for the v6 upgrade I’m reluctant to downgrade to v5 again, but that’s the only one that currently works with Affinity…

On an M1 MacMini running MacOs Ventura (13.3.1)

Same problem here - Nik Collection 6 worked on Affinity Photo V2, but not after upgrading to Affinity Photo V2.1.
Now, the “Apply” button is missing on all of the Nik Collection 6 plugins.

I’m using Mac OSX Ventura 13.3.1 (a) on 2019 iMac w/ 8 cores and Radeon Pro 580X 8 GB graphics and 32 GB memory.

the problem is that you installed a first day release update. lesson that I learned, always wait 2-3 days and check forum see if there is any issues, specially with 2 different software update within days apart… reverting to nik 5 won’t fix the problem, going back to v2 instead of v2.1 should fix it though as it work fine.
that’s probably going to be a week before it’s fixed.

1 Like

same here (see my last thread), but I have the same problem with the stand-alone-Version of NIK 6. So without Affinity I miss the “Apply-Button”.

On an M2 MacMini Pro running MacOS Ventura

Same issues with AP v2.1 and Nik Collection 6 under the latest version of Monterey–no “Cancel” / “Brush” / “Apply” buttons, all the “v6” apps don’t return control back to AP, and what looks like older versions of the app–HDR Efex, Sharpener, etc–simply don’t run at all. I sure wish I could return to AP v2.0, but I don’t think I can do this through the Mac App Store and I don’t have a recent backup. My bad on the latter! :frowning:

yep, that’s the problem from the App Store, you get only the latest version.
you can use Time Machine, that way you’ll go back in time before you installed them, just another option for you as you don’t have the last installer.

Since I have an older MacBook Pro which isn’t my main editing platform, I don’t bother with Time Machine backups. I guess there’s a lesson here… :wink:

check, if you can create an Affinity account …

I already have an Affinity account. Are you suggesting that I can bypass the App Store and download v2.0 direct from Serif? I always thought that if you bought an app through the App Store, you were locked in? Boxing or whatever they call it?

For anyone who’s interested in getting Nik 6 working until this AP 2.1 snafu gets fixed:

  1. Uninstall AP v2.1

  2. Use the Nik uninstaller to remove Nik Collection 6

  3. Log into your account on the Serif website, then, if needed, do a Google search to locate the Serif webpage showing download links for the current version and several of the prior versions

  4. Download and install a prior version (I picked the version just before 2.1 which is 2.0.4)

  5. Re-install Nik Collection 6


P.S. I originally bought AP through the Mac App Store, but it didn’t seem to matter that I installed a version from the Serif website.

that’s sounds good, maybe serif change the way it work as you couldn’t do that before. App Store and serif website were just 2 different account.

correct, you can not change your account from App Store to direct download

you can actually, easier than what @Alan9940 posted actually.
login in your serif account and go in oder history, you’ll find all version you bought and download them again, from App Store or Serif website.
about uninstalling nik6, I think you can just run the installer again and it will overwrite the existing anyway plus install in AP.

Not true in my case, if we’re talking about logging into The only items that show up in my Order History or Product Downloads is the stuff I bought directly from Serif. AP v1 nor v2 that I bought through the Mac App Store are listed anywhere on my Serif account.

I, too, always thought that I couldn’t download and install any app from the maker, if it was originally purchased through the App Store. Don’t know if it’s just me or Serif has a different arrangement, but it worked and I’m a happy camper!

You’re probably right that one can simpy re-run the Nik installer, but I’ve had it drilled into my head for so many years by DxO to make sure you run the Uninstaller before installing the suite. That could only apply to, say, moving from v5 to v6 but it certainly doesn’t hurt to uninstall first.

hahaha yes login not losing =/ (auto-correct)
I was saying that because after checking my serif account I saw I could download them all, my first AP purchase was from App Store, then I went to serif website instead due to conflict for downloading from one another.

Interesting. So weird that it’s different for different people. Either way, anybody having issues with AP 2.1 can revert back and get things working. Hopefully, DxO and/or Serif will get this issue resolved soon.

I rolled back from AP v.2.1 to v.2.0.4, and did not uninstal/reinstal my trial version of Nik6. All seems to work fine again.
I am following this thread on the Serif forums: V2.1.0 Affinity Photo breaks Nik Collection - V2 Bugs found on macOS - Affinity | Forum
where Nathan C (Staff) mentions that the developers have been notified of the problem.

It all works with the latest Nik 6.1 update.
I tried Viveza, ColorEfex and SilverEfex all OK on Affinity 2.1.


1 Like

wait… there’s been an update?


can’t find what’s new in 6.1 but there is an update available from 6.0.0 to 6.1

yes …

screenshot from →

1 Like