Nik 5 applications showing blank canvas on loading any image file

I thought my problems were over with PhotoLab 5 and Nik - both working fine and dandy (at last after the Nik 4 debacle with SEP!!!) until windows update installed KB4023057 and KB5013889 on July 14! (I had also just re-installed Viewpoint and Nik but uninstalled both just in case) Now any of the Nik apps (appear) to load an image but the working ‘canvas’ part of the screen (and recipes) is just black, all sliders etc are there plus all the extra filters etc and can be adjusted as usual but the screen is black! It happens either loading from Photolab or standalone, with any image file type. I’ve had to uninstall and revert to the last known working Nik on my system ( to regain control.
System is Windows 11, AMD 5950, 16G ram and plenty of disk space.
Back to the drawing board!
Asking here if anyone else had a similar experience before opening a case with DXO???

Are you using multiple monitors? If so, does it matter which screen the Nik Collection apps are opened on?

Hi Greg, only 1 monitor.

Strange – couldn’t you re-set your canvas back to your liking → Nik preferences?

@Wolfgang, the only ‘canvas’ preferences I can see is the background colour - which is what it shows after appearing to load an image, whether it’s black, white, grey etc… I don’t think Nik is completely loading images as the loading ‘bar’ gets less than a quarter of its travel then disappears, I’ve tried using the GPU, dragging and dropping a file (tiff and jpg) and using Control ‘o’ to load an image all with the same results - blank screen, even though Nik is telling me the image name and camera used along bottom bar!

All rather strange!

Hi Andy,
that’s indeed strange and yes, it looks like the pic is not loading. Does (or did) this happen w/ any pics?

As I’m not on Nik 5 (anymore), I suggest you contact the support.

@wolfgang, yes any pic… I’ve just tried all 9 of the apps (as I only tried the ones I use) and it appears only the newer updated apps with the new look won’t load images, that’s - Analog Efex Pro3, Color Efex Pro5, Silver Efex Pro3, PerspectiveEfex (not even the samples!) and Vivenza… The other 4, that’s - HDR Efex Pro2, Dfine2 and both the Sharpener Pro3 apps load images ok!!!

I think it’s back to opening a case with DXO time :frowning_face:

Well I’ll be…! It may well appear that a Microsoft Colour Control Profile (wsRGB.cdmp, part of the Windows Colour System and not fully implemented yet) was causing the problem and just released Nik Collection gives you the option of using the default profile, see pic, all seems back to normal! Well Done DXO!

1 Like