Nik 4 install fails on Windows 10

The Windows installer fails when trying to install the new Nik Collection 4.
I have tried downloading several times. I have tried starting install as Administrator. And in every case the installer fails with an exception 0xe0434352.

Exception: System.InvalidOperationException
ved InstallerUI.WixBootstrapper.Run()
ved System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
ved System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
ved System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
ved System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
ved System.Threading.ThreadHelper.ThreadStart()

I’m not seeing this problem on my Win10 system, Jan.

Perhaps something is “locked” - - Have you tried doing a system restart ?


John M

1 Like

Hello, the problem was in the set language Czech). I had to switch my win 10 system to English, reboot and install nik 4. Then revert to Czech again. The fix for this problem will be in the July update of the program.
Thank you for trying to help. Jan Vizner.

Yes, the support told me. I am using Danish. Apparently it happens to all non-English Windows.

But are you convinced that the problem is really solved (I am not). Will the individual programs/addins run as expected? Why should this be only in the install, if it is a language problem?

If you try it yourself you will know whether or not it works.


I am not a tester - I am a photographer spending my time best at doing just that …

It’s not about testing, it’s about installing software you’ve already paid for. But that is up to you. You can wait for the fix.


It is totally about testing, when I am left uncertain what will fail when I try to do my job.

But yes, I opt to wait for a program that works, - and yes, it is extremely annoying to pay for software that doesn’t work … :wink:

In my experience, every user of software is a tester, due to having to find out if the software meets a particular need and doesn’t fail due to previously undiscovered problems. It’s the nature of the beast. I, too, want things to just work out-of-the-box. I don’t fault individual professionals or organizations for being reluctant to upgrade because of the need to make sure that the upgrade (a) works and (b) is worth the expense of time and money. It isn’t a no-risk decision.

In this case it looks like support has determined that it’s an installer problem. The installer is separate software, and so mistakes can be made in its development that aren’t made while developing the actual software that will be used. The installer can therefore be expected to handle things like localization (language settings, time settings, etc.) differently from what it’s installing.