Nik 4 and Affinity Photo

Nik 4 cannot be called up via Affinity Photo because the software such as PhotoLab 4 is not native to the M1.

All modules of Nik 4 (4.0.8) can be called from AP (1.9.3) on my iMac 2019.
Perspective Efex does not cooperate nicely - it’s a known issue though.

This is how I set up AP to work with Nik:

Hint: I use two user-accounts on my Mac and in order to be able to use both accounts, the Nik Installer must be run under both users. Adding a separate place for plugins for AP makes things more complicated. If Ps is installed, the default location of the plugins (as shown in the screenshot) works just fine.


I am running Affinity Photo on Mac mini M1 (2020) Big Sur 11.4 and Nik Collection 4. With exception of perspective tool, everything runs. I had to set the Affinity Photo to run under Rosetta and then followed the instructions in the user guide for installing the Nik Collection to run on Affinity Photo.

Hope that helps.


1 Like

On my M1 machine, I also had to set it up to work in Rosetta.

I’m having another problem after the most recent update, this one on my Intel machine running the latest OS. NIK starts up via photoshop’s filters menu, it creates previews and will display any preset I choose, then, when I click OK, nothing happens. It does not create an extra layer, it does not impose the filters, it just does nothing. Over and over and over again. I have tried reverting to the previous version of 4. I have gone down to 3. It worked one time. The worst problems, as we know, are intermittent. It is now consistently broken. Not sure when I’ll have time to do more troubleshooting. I emailed DXO and offered to send in logs if they could direct me, but no word yet. I also don’t have time to spend hours trying to figure this out. I remember something along these lines years ago, maybe in the pre-Google NIK days, when one version actually did finish the job, but NOT on a separate layer. They finally fixed that.

Just had to run the Adobe Cleaner tool for another reason - ACR stopped opening NEF files. After nuking the system and reinstalling, NIK works for now! Just wanted to share.