Nik 3 crashes my DXO Photolab 3 MAC

So I have MAC (catalina), and DXO photolab 2, which I just found DXO isn’t compatible with (even though I paid for it with a “lifetime subscription” for DXO 2). So I downloaded trial version of Photolab 3, which Does works, however NIK collection 3, is still crashing DXO Photolab 3 when used together.

Do you know if Nik Collection works AT ALL on MACs anymore?

  • I hope this wasn’t an obvious scam to force people to upgrade ($$$).


Hello. I see you have voiced a number of concerns. First of all, while PhotoLab 2 was initially incompatible with MacOS Catalina, it has since been made compatible:

I hope you don’t mind a few questions to clarify the problem you’re having. When you say that Nik Collection 3 is “still” crashing PhotoLab 3 when used together, do you mean that it also couldn’t be used with PhotoLab 2? Was there a time when Nik and PhotoLab were working together on your computer without crashing? Can you explain what you are doing when the crash occurs and what the crash looks like? And have you already opened a support ticket at

1 Like

I don’t know the specific Mac rules.
But if PL just saves an intermediary file and sends a command to the os to open a nik program with that file, how can that affect PL?


So I initially had Nik Collection working with a 3rd party program plugin, which worked, but when I upgraded and bought DXO photolab 2 with Nik Collection, it never quite worked right.

As of now, DXO Photolab doesn’t work at all with my computer (2019 Macbook Pro Catalina 10.15.6).

The crash happens at the the precise moments I try to use Nik Collection to a raw photo. Since experimenting, it works about 15% of the time, the other time it freezes up the software and doesn’t respond. The rest of my computer has no other similar problems.


I’m not sure, but what you described is exactly what is happening.

More detailed information is needed. If you just export an image from PhotoLab to TIFF instead of to a Nik Collection application, does it work? And then, without using PhotoLab, if you open that TIFF image in one of the Nik tools, does that work?