New Computer - Photolab 5 DeepPrime doesn't work

I purchased a much better computer, and redownloaded Photolab5 onto the new computer. I have imported my photos over and since my new screen is OLED I went to change the white balance of some photos as it has more accurate colours. However when I go to export the photos now there is noise and I can’t seem to get rid of it. It seems Deepprime does not work correctly on the new computer, but it worked amazing on my old computer.

I have gone back and changed the photo to the exact same specs on my old computer (including white balances.) When I export the photos on the old computer Deepprime does an amazing job, however on the new computer it seems to do a horrible job. I have the computers side by side, open the same image up on both computers, keep the specs the same, but the photo looks awful on the new laptop.

New computer

Old computer

The new computer is windows 11, but I don’t see how this should affect. PL5 shows as the most up to date. Anyone else run into this?

Hello and welcome, Will. Your “new” image shows a lot of moire, which DeepPRIME can handle to some extent but for which there is also a separate adjustment in PhotoLab. Are you sure you’ve kept all the image adjustments the same in PL5 on the new computer? If you’ve checked everything and can be sure it’s all the same, then what is the hardware in your new computer? (CPU, video card, amount of RAM, etc.) Are your video and system drivers all up-to-date? And is PhotoLab configured to use the graphics processor for DeepPRIME images (in Preferences)?

Please be aware that you might need to share the RAW file and .dop sidecar with us or with DxO technical support ( to figure this out.

It appears using Prime, the image looks alright and noise reduction is the same from old to new computer (and both look good), but Deep Prime is the problem.

In the correction preview (the big window) it appears to look good and looks like DeepPrime is functioning properly, but you can still see noise in the DeepPrime window it is still noisy. When you export it is the noisy version.

Hi Will and welcome,

Could you upload your RAW file to a file sharing service such as Dropbox, pCloud, Wetransfer, etc. and then post the link here, so that we can take a look at it?

always check in the small window

the big preview will not show you the denoised result except after having exported e.g. to DNG

1 Like

Yes! Thank you!!! The preferences is what fixed it. Performance was set to default which was using the graphics card. I had to switch to CPU as it was defaulting to the video card which is a Intel ARC A370M, which I guess isn’t good enough.

Other specs are:
Intel® Core™ i7-12700H
Intel® Arc™ A370M graphics with 4 GB GDDR6 VRAM
16 GB LPDDR5 4800 MHz memory

sad that my graphics card in my old i5 $400 computer did a better job than the new $2000 one :frowning: