Mouse wheel causes crash in PL 5.3.0

Not been a problem before, but now when I try to zoom in/out on an image (only tried RAW CR2 files) PL immediately crashes. Using Elite version on Windows 10.
Crash dump files already uploaded via the reporter built into Photolab. One of the references is 0A67FCBE-78DB-48F0-B1E6-FF09DC56C15E. Ticket number is 365460

I was unable to recreate the problem.


That’s interesting. Crash dump xml file certainly shows an error in that event handling. Maybe it is specific to a particular configuration (video driver?)

Here the same: I have no problem with “Mouse wheel zooming” - all fine

I just had the same problem, when I was zooming out with the trackpad of my laptop. An error report has been sent, and the program crashed completely. On Nikon Raw files, on Windows 10.

It is reproducable, always when I zoom out far enough (14% in this case).

   <Exception><![CDATA[System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at DxONET.UI.UI.ZoomManager.ZoomManagerUtils.GetPreviousOrNextZoomValue(Double zoomFactor, Double steps, Double fitValue)
   at DxO.PhotoLab.Controls.DisplayGPU.GpuViewer.GpuDisplayBaseMouseWheel(Object sender, MouseEventArgs e)
   at DxO.PhotoLab.Controls.DisplayGPU.GpuViewerContainer.MouseWheel(MouseEventArgs args)
   at DxO.PhotoLab.Controls.DisplayGPU.GpuViewerContainer.OnMainWinMouseWheel(MouseEventArgs args)
   at DxO.PhotoLab.UI.MainWindow.OnMouseWheel(MouseEventArgs e)
   at DxO.PhotoLab.UI.MessageHook.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at System.Windows.Interop.HwndSource.PublicHooksFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)]]></Exception>

After this has happened once now, it is happening currently every time on every picture as soon as I am zooming in our out with the trackpad. Even a slight touch crashes the program.

I tested again and still don’t see this issue. If this was a common problem there would probably be a lot of complaints by now. Hopefully DxO support will sort it out quickly.


I’m hitting the same issue when zooming into an image. Seems to happen whether I’m previewing or editing. Occurs fairly frequently, but there’s been a few times I’ve been able to actually work on a photo without issues… Hoping this gets resolved soon.

I have the same issue. Sent an error report already. I hope it’ll be sorted soon.

edit: I updated the mouse driver ( I had the generic windows driver ) and now looks ok !!

mine too, started today and now it happens whenever I touch the mouse wheel …


In our analytics, we do notice a crash for some users when zooming in/out but we are unable to reproduce this issue so far.

Could you share with us the following information:

  • Your Display resolution + Windows scale factor
  • Image dimensions + Maker/Body
  • Are you using the mouse wheel or the touchpad (if on a laptop)
  • Are you using a specific mouse model with dedicated drivers?

Could you also share with us by private message:

  • One of your image + .dop file to help us to reproduce the crash
  • You settings file located in C:\Users%USERNAME%\AppData\Local\DxO\DxO.PhotoLab.exe_StrongName_addo3jomrfkt2faiwwfxxb444r1xfvlh\


1 Like

As requested:
Main monitor for PL main window - BenQ SW271 @3840x2160, scale 150%
Second monitor (for tool palettes) - generic SVGA @1920x1080, scale 100%
An example image is 5472x3648 px from Canon 7DmkII, BUT the problem exists with ANY image of any size and any type - RAW, jpg, TIF. These might have come from a phone camera, scanner, etc. as well as my Canon DSLRs
Microsoft Wireless Mouse 2000 model 1416. Presumably its specifc driver but as it was plug-and-play I have no idea!
Image and settings to follow by DM

  • 1920x1080 (1.25 scale factor)
  • Any image type
  • Touchpad of Asus Laptop
  • Are you using a specific mouse model with dedicated drivers?: ASUS Zenbook UX433FA with Touchpad firmware 2.0

I have just tried to connect an external mouse (Logitech M280), and the problem does not exist with the external mouse. So it seems somehow to be related only to specific mice/touchpads.

1 Like

Thanks for the details.
We were able to reproduce the crash and are working on a fix that we will release very soon.

Thanks for your understanding.


Good to hear. Thanks for keeping us informed :+1:t2:

Hello guys,

The issue has been fixed and you’ll be able to test it vs PL5.3.1.

Svetlana G.

1 Like

I can confirm that v5.3.1 has resolved this issue for me

1 Like

Me too, it works now! Thanks for the quick fix.

1 Like

Thank you for the confirmation!