Module nikkor 18-140 3.5-5.6 ED VR error 404


I have a D300 nikon with a 18-140 AFS DX 3.5-5.6G ED VR and I get a error 404 when I try do download the module (optic pro 11 elite)

And it seems that manually downloading from a depot site is not possible anymore, all links are dead.

Thanks for your help



funny, as I had to process my pictures, I"ve installed photolab4 on a other computer, just in case I had more chance.

And the module downloaded in a second.
copied it to my optic pro computer and I can now process images.

Can someone give an explanation to this ?

different servers ?



Good morning,

@Marie could you, please, have a look?

Svetlana G.

Hello Svetlana

Just make a test, and no chance, still the same error 404.

But if I try another one like 70-300 f/4-5.6D ED the download works.

Best regards

Jean marc

Hello @JMJ ,

now you should be able to download the module (or at least in 15 minutes if you read my message at the moment).



Hello marie

Now it wroks.

many thanks

One sde question, I have a DXO 8 ad t seems that the modules can’t be downlaoded (not in the list) and if manually installed, said “to be updated”.

normaly this D300/18-140 modules is shown a compatible from DXO 7.
any recommendation on that .

Best regards


Hello @JMJ ,

this module is not in the list of modules of Optics Pro 8.
There might be an error on our website about compatibility. I will fix this. Sorry for false hope.


I’m using Optics Pro 9, and I used to be able to download the modules, but not anymore.
Also, in the manual, it says that you should be able to download them manually, and cannot reach the site:

Using a D7100 with Nikon 50mm, which worked fine before with Optics Pro 9.

The link was automatically changed:
http:// www . /intl/photo/dxo_optics_pro/manual_download

Hello @HidRo ,

manual download is not possible anymore. You need to create a support ticket for that via
Answer with modules will be quick.


Thank you!