MacOS Catalina public beta testing issue

Initial testing of current version of DxO PhotoLab (2.3.0) has major issue with MacOS Catalina Public Beta (10.15 Beta build19A501i).

  1. Using the PL browsing window will show “This folder does not contain any images”
    regardless of file types within the folder (NEF, JPEG, TIFF, etc.).
  2. From macOS Finder, opening any image file with PL results in PL opening but
    no image opened.
  3. This could one I am just adding and not sure who is at issue but from opening from
    Adobe Bridge results in similar issue.

Would like to know if any one else here is testing and has issue or if the folks at DxO are aware of the issue or are even testing PL in Catalina yet?

Obviously further testing is fruitless.

DPL works nicely on macOS Catalina public beta 2, which has been made available a few days ago.

Search the forum for more on this combination.

What I have is the current public beta based on all available info (see build number in post). There is no update available according to Software Update.

This morning I also tried re-installing PL and still getting the same result.

How did you install Catalina Beta, clean, upgrade, or clean and migrate? I did an initial clean install to see if there were any major malfunctions and then used Migration Assistant to bring in my “work” Mojave installation. While everything else seems to be functional, it seems PL to be the only one with a major issue. Perhaps since I migrated some pref file is hosed and will look into that.

I have done additional testing and found some possible clues as to the issue.

If I access images on an external drive, PL works properly in terms of showing the images and being able to access and work with them. I was prompted if I wanted to allow PL access to the drive.

It seems that the issue has something to do with access files on the “main volume” with the scheme in Catalina. It seems what ever framework for accessing files that DP uses is not playing well with Catalina or Catalina has a bug or perhaps a little of both. So far, the other apps I have checked out don’t have an issue with file access
(surprisingly Adobe Bridge CC is one that does works).

I did some checking in the Console, and this error that I found seems to indicate some sort of issue with path mappings. This happens every image access attempt.
The error:
volume mount point /System/Volumes/Data does not match path /Users/woodman/Pictures/CurrentLibrary/2019_07_06/raw

I am just doing some part in trying to help people at DxO with what is coming down the road.

Since I can access external drives, I will see if I run into any other issues in an attempt to help.


Okay, last post for today and at this point I will wait for the next Catalina Beta.

I created a separate volume in the “container” that I have the Catalina Beta install in. I moved some photos there and all worked just fine. The issue of no images seems to be limited to those in one’s home directory.

Also did some fast and furious things with PL and I found only one other issue. The dropdown box for image enlargement adjustment seems broke. Selecting blanks the entry field and the image goes to minimum size with no settings working. The “fit window” and “1:1” work just fine.

1 Like

Thanks for all your hard work troubleshooting Catalina early. It will make life much easier for other PhotoLab users.

Thanks! I always like to try and get ahead of the game to find out what I can or cannot expect. Especially with this transition from 10.14 to 10.15 as a few significant changes are taking place.

BTW, I had mentioned I was surprised Adobe Bridge had no issues. Well they do as well and also seems related to the issue with PL as well. It seems their issue is at a higher directory structure level. But that is Bridge and won’t go into much further detail.

It seems that Apple may have made changes to the file browsing API and also the “Open with…” API. Or there are path “translating” issues with changes to the underlying boot volume structure. I did do a bit more testing and as long as files are located on a non-boot volume, be it just another partition or external drive, everything behaves normally. Spent quite a bit of time yesterday working with PL and only that one dropdown box mentioned earlier seems to be the only issue in terms of the function of PL.

1 Like

I just installed the latest Catalina Public Beta (10.15 Beta (19A512f)) and am happy to see that all the "This folder does not contain any images” issue was resolved when those files were located in the home directory or on the “boot drive”. So, it seems this was an Catalina issue and perhaps they listened when I sent the feedback (and maybe lots of others including developers).

So, as of now, all seems to work as it always has in the PhotoLibrary/browser pane. The new Catalina Beta update did not seem to add any additional issues. There is still the one minor issue I mentioned previously, the zoom dropdown is still broke. Attempting to select any percentage in the drop down still reduces the image to some very small size and the choices for zoom values disappear. Also, this occurs as soon as the arrow button is clicked. Selecting the “Fill Screen” restores the image and 1:1 still produces 1:1.

1 Like