[MAC] New Version 2.1.2 hangs on opening folder with .dop files from previous versions

Its just a theory, but it looks like that as if the new version of PL2 I just installed has for any reason problems to load folder with .dop files created by the old version. I am on Mac.
First I thought its caused by the xmp file created by FastRawViewer. But its also with folder I didn’t opened with FRV.
Because PL2 always tries to open the last folder, I have to move this folder first, because otherwise it will hang again.

I just got from the backup version PL 2.1.1. This works, opens the folder without a problem, where P.L. 2.1.2. fails.
So before you update, keep a copy of you old version of PL 2

No issues here so far.
iMac, late 2012, macOS Sierra.

Hello KameraD,

Sorry for this problem, if it is possible could you provide us the picture and sidecars where PL2.1.2 hangs ?
You can use upload.dxo.com to provide us the pictures ? (notice, as Support ticket number please add your user name KameraD)



Sure LCDI, I will do, thx.

I’ve an issue with PL 2.1.2 hanging with Mac; have sent a support ticket, including the log file that was also sent to Apple. Tried a reinstall, ran Onyx … Nothing working.

Seems weirder for me than “just” the old dop files.
I renamed the folder it was trying to open on first launching it; then Photolab worked ok.
I thought all was well.

But just found it hanging again - after launched, and tried switching from Customize to PhotoLibrary.
Force quit, restart; again hanging.

Again, renamed the folder it was trying to open; and again looks to be working okay, including with that renamed folder.

So, seems there’s something odd on launch, and initial attempt to open a folder in PhotoLibrary.

Still not good: went for lunch, computer woke from sleep and PhotoLab hanging

Just again changed a folder name, so PhotoLab wasn’t aiming to open anything after I force quit, and relaunched.
Again, it worked.
But a folder with a few hundred images: I see new dop files being created, and this is taking some time; Activity Monitor reporting 115%CPU usage.

So indeed related to dop files, I believe; but also to PhotoLab trying to update these files, and maybe too ambitious in doing so - could it be throttled or something?

Hanging on my Mac as well, although it’s not due to .dop files as it happens when there are none. I think it’s a size/memory problem. When there are a lot of files in the folder that automatically have a preset applied it seems to cause the problem. Restarting my Mac and reopening the folder solves the problem for me. However, this is new behaviour as it worked fine before. I have a 4,2 Ghz intel core i7 with 40GB of ram

Are these photos and dop files local or on server?
If local, where?
Are you on 10.13 or 14?

My photos are just on an external USB drive. For my case I don’t think its related to that. 2.1.1 has no problem at all with any of those folders. Only 2.1.2 hangs on certain folders. System HighSierra 10.13.6

I find it hangs as soon as library folder is changed and have sent a support request. As all older folders will have .dop files this could be the fault you describe & as so many are experiencing it, hope a patch will come soon. 10.13.6 on 2017 iMac. I have had to go back to 2.0 as that is the last download I have as opposed to auto-overwrite

Anything new to this? Still hanging on several folders.

Yes, while in discussion at DxO support, it occurred to me the problem might be with size of my library and/or cache setting. I had it set from ages ago at 100MB, put it up to 10000MB and it has now performed fine for an hour or so deliberately pushed over several ancient folders…just climbed through 300MB to 330MB and rising. (that is in preferences>advanced; NB as in the situation of it hanging, you can’t do anything, you have to run an older version of PL2, change it there, re-start the older edition for it to take up the new setting, and only then try again PL2.1.2 build 20). The other thing support did was give me link to a download calledDxO PhotoLab 2.3.app

1 Like

Thanks for describing your situation and handling it. And would be nice if DXO could also provide me with this link, though I initiated that topic. But never heard again sth from the staff, thats why I posted here again.

Working now with PL 2.3?

same issue with my MacBook Pro, 3,1 GHz Intel Core i7 (OSX 10.14.2)
Once opening a folder (e.g. with TIF files) and trying to select the pictures for export to JPG, DxO hangs up :frowning_face:

When we can expect the hot-fix?

Can you provide me the previous 2.1.1 version?


…one day later - surprise surprise, the hot fix (build 25) arrived and has - at least in my case - solved the issue :+1::clap:

Many thanks for your quick respond!

1 Like

Indeed, working for me now too. Thanks for the hint and to DXO for the fix and update.