Local Adjustments viewer content can become invisible over time (PL 5.3.1)


After working in PL 5.3.1 for a while in two folders, I minimized the window for about a day, then returned to it, selected the first folder I was working in, made a virtual copy of one of the TIFF images, selected that VC, then selected Local Adjustments. No overlays appeared in the viewer. I could right-click and get the brush menu, select a control point, and place it - but the control point, equalizer, etc. were all invisible. I could press M to show the mask - that worked - and could use the Del key to remove the control point, but that’s all. Switching images didn’t help. I had to shut down and restart PhotoLab to get Local Adjustments working again.

Also, when PL shut down, the mouse froze for about 20 seconds.

More info: I run Windows 11 Pro with an AMD Ryzen 7 and GeForce RTX 3080. Drivers are up-to-date. I occasionally add a second monitor (an HDR 4K projector) for certain tasks but not photo editing. Am wondering if activating that for a while might have messed something up in PL 5 on the primary display. Normally, there are no problems - but just now I turned the second display on and the Edge browser started showing colors all wrong (restarting it fixed that).

Good morning @Egregius!

Could you, please, provide us with the logs from that day?

Svetlana G.

Yes, this issue has been around for quite a while … It’s “fixed” by stopping PL and restarting the app.

John M


Here are the logs from June 29-30.
DxO PhotoLab 5 logs.zip (407.7 KB)

Thank you! We’ll investigate.

Svetlana G.